Jump to content

Error 401: You do not have permission to access th


Guest
 Share

Recommended Posts

Error 401: You do not have permission to access that page. Please ask one of the super users to grant this for you.

I installed it o.k, went to login for the first time using the user/pass setup during installation.

When I click "General Settings" to start customizing, I got the above error.

Please advise...

Thanks!

Link to comment
Share on other sites

couple of things....

A) This is now the v2 support area, the area for v3 is above it :wacko:

:P This has been answered about 10 times in the v3 area (theres barely any threads in there, so it should be easy to find)

Link to comment
Share on other sites

Hi

I would have the same problem as trinity, I have just reinstalled cube cart and have a couple of probs,

1: i get an error 401 get permition from a super user- ive tried to find it on the forums but getting confused with what people are have replied to in the past. So can someone help please?

2: I have reinstalled my cubecart from scratch a couple of times and now have the added problem of it not accepting my registration key, telling me it has

allready been used. any ideas?

Regards Nick ;)

Link to comment
Share on other sites

Hello Nick100,

Try this, I found it some where in this forum, and it works for me too.

Like a number of other folks, the fairly simple .ht access and ini_set fixes didn't work for me. Brooky had suggested that changing $_SESSION['ccAdmin'] to $_SESSION['adminUser'] would resolve the conflict -- which it does.

The change needs to be made to the following files:

\admin\login.php

\admin\logout.php (2 places)

\admin\adminusers\changePass.php

\admin\includes\auth.inc.php (3 places)

\admin\includes\footer.inc.php

\admin\includes\header.inc.php (2 places)

WARNING (as noted by Brooky): DO NOT CHANGE the $ccAdmin array, which is also foud in some of these same files.

Can now access all the Admin setting files.

Take it easy, step by step, then You'll see, and first make an backup, okay.

From the Cool Guy, ;)

Link to comment
Share on other sites

Guest twisted

When you say "re-installed from scratch"...does that include running the installation right from scratch [i.e. where you nitially set up the database tables and write the config file]?

Because if so, then that would clean out the database, and it would not have a record of your license key.

Simply re-uploading all the files does not qualify as a re-install from scratch, and your license key would still be stored in the database.

Link to comment
Share on other sites

Hi

Thanks for that Micco, i'll give that a go.

In reply to Twisted, i first installed and installed the key but had a problem with the 401 error as i said before so i assumed that i had done somthing wrong and deleted the data base and site and re-ftped and re-installed the whole site.

After doing so i realised that i was getting the same problem with the 401 error and it wouldnt let me install the key and it keeps telling me ''Sorry but the license key was invalid or has already been used''

Regards Nick

Link to comment
Share on other sites

Hi Micco,

You must be some kind of super star, thanks for the help it was fun. One question though, on the last file you said there was 2 but i could only find 1, is that ok or should i go and invest in a pair of glases! It seams to be working though.

Regards Nick

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...