Jump to content

mysql error in installation process

Guest bugis

Recommended Posts

Guest bugis

Dear all

I have problem on installing the cubecart (v4) at hostgator, this the problem:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ismail'@'localhost' (using password: YES) in /home/rahi4903/public_html/classes/db/db.php on line 42

Access denied for user 'ismail'@'localhost' (using password: YES)

I have tried the following

1. set and check db, username and password at gator cpanel on mysql, everything was fine

2. I tried to peek on /db/dp.php on line 42, but i do not see any setting

Please help...

Link to comment
Share on other sites

  • 2 weeks later...

I am having this problem too and I cant find out what is causing it...

This is an easy fix even though I struggled with it for 2 days. Anyway...

Go to control panel in Host Gator and click on mysql databases. Delete whatever

you created, then create a new database called 'cubecart'. Next add a user name

and password. After that set your user permissions to 'ALL'.

Note that your database will look like this: yourname_cubecart and your user name

will look like this: yourname_username. If your confused, simply leave control panel

open in another window while you install cubecart. When you get to screen where you

enter the above info, either type in the above info in the appropriate fields, or cut and

paste and then use the database password you set up in mysql. Next, fill in the rest of

the blanks and leave the box empty that says 'subscribe to cc mailing list' and you

should be good to go.

Link to comment
Share on other sites

Guest jarmitage

thanks for this -

its worth pointintg out I am not with host gator and my hosts MYSQL does not have a point in the creation of databases to assign a password so it was this that was catching me out.

I used the USERNAME password

left the mailout checkbox UNTICKED and this worked...

thanks so much

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...