Jump to content
  • Posts

    30
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by [email protected]

  1. no, it wasn't - but I've ticked it now and saved.
  2. thanks for the reply: CubeCart Version 6.4.4 Yes, there is: <title>{$META_TITLE}</title> {include file='templates/element.meta.php'} <link href="{$CANONICAL}" rel="canonical"> <link href="{$ROOT_PATH}favicon.ico" rel="shortcut icon" type="image/x-icon"> {include file='templates/element.css.php'} {include file='templates/content.recaptcha.head.php'} {include file='templates/element.google_analytics.php'} {include file='templates/element.js_head.php'} </head> <body> Yes, that file is there - : {if isset($smarty.cookies.accept_cookies) && $smarty.cookies.accept_cookies=='true'} {literal}<script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', '{/literal}{$ANALYTICS}{literal}', 'auto'); ga('set', 'anonymizeIp', true); ga('send', 'pageview'); </script>{/literal} {/if}
  3. thank you for the reply - not quite sure I understand it though I don't really mind if i use that code or not, all i know is that the analytics isn't working and hasn't worked with cubecart since day one of our install (i only just found out today). I have have done is put our code in the area within store administration as that is all I thought we needed to do to get it working? What else could then be stopping it working - assuming I am not required to put any code in manually - just the analytics userid into the admin area please?
  4. Hi, I am trying to configure Google Analytics for my site. I've put in the Analytics ID number in the Store administrator settings some time ago, but it has never worked - nothing appears on the google console. I haven't however put in any tracking code as I wasn't sure where to put it. I see that it is supposed to go in the head section of every page. I've searched the forum and others have said put it in main.php - however which one? I have tried putting it in as the first entry under my templates/foundation main.php and all it does is prevent from the page from loading. Is someone able to assist as to correctly setup analytics for ALL of the pages on the website please? thanks in advance. This is the code I need to put in: <!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-11031594-1"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'UA-11031594-1'); </script>
  5. thanks, but that doesn't really help me - or potential customers. I wonder if anyone else can chip in here please?
  6. thanks for the reply. Yep, it is trying locally. I did exactly what you said and get this even when I put in New Zealand as an address. Version is: http://www.vintagedesigns.com.au/admin/skins/default/images/1.png All In One Shipping Advanced shipping module that can calculate shipping based on the weight, subtotal and number of items in the order. 1.0.16 SESSION: '__client' => 'ip_address' => 203.40.188.71 'useragent' => Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:86.0) Gecko/20100101 Firefox/86.0 'session_start' => 1615183126 'session_last' => 1615183128 'language' => en-GB '__recaptcha' => 'error' => The verification code was incorrect. Please try again. 'confirmed' => '__system' => 'token' => 660ff4ce47d9ff2dbe216dfb15678efa '__basket' => 'contents' => 'c8a0fd9d7ff88de4f9924c873a949e3d' => 'id' => 116 'quantity' => 1 'digital' => 0 'cost_price' => 0 'option_line_price' => 0 'total_price_each' => 20 'description' => Spiral Bound Publication 2nd edition Chicago State University Author Stella V. Remiasz Copyright 1986 Fourth printing 2003 Published in the USA by&nbsp; Hat Tree Studio Text book for millinery students covering in depth both millinery d 'name' => Hats: Design and Construction 2 Revised Edition Stella V. Remiasz 'product_code' => HAAY9JN53 'product_weight' => 0.45 'product_width' => 0.0000 'product_height' => 0.0000 'product_depth' => 0.0000 'tax_each' => 'tax_id' => 4 'amount' => 2.00 'tax_inclusive' => 'tax_name' => GST (Standard Rate 10%) 'tax_percent' => 10.0000 'option_absolute_price' => 'weight' => 0.4500 'discount' => 0.00 'subtotal' => 20.00 'total_tax' => 2.00 'total' => 22.00 'register' => 1 'delivery_address' => 'postcode' => 2700 'country' => Australia 'state' => New South Wales 'state_id' => 561 'country_id' => 036 'state_abbrev' => NSW 'country_iso' => AU 'country_iso3' => AUS 'user_defined' => 'estimate' => 'billing_address' => 'postcode' => 2700 'country' => Australia 'state' => New South Wales 'state_id' => 561 'country_id' => 036 'state_abbrev' => NSW 'country_iso' => AU 'country_iso3' => AUS 'user_defined' => 'estimate' => 'shipping' => 'offset' => 1 'name' => All_In_One_Shipping 'product' => Local Pick Up 'value' => 0 'tax_id' => 3 'tax' => 'default_shipping_set' => 1 echnical Details CubeCart Version 6.4.1 PHP Version (7.3 Recommended) 7.4.15 MySQL Version 5.5.5-10.1.48-MariaDB Image folder size Calculate Download folder size Calculate Max. Upload filesize 2M Browser user-agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:86.0) Gecko/20100101 Firefox/86.0 Server Software Apache/2.4.6
  7. Hi, we have setup our shipping options for the different zones of the world. There are six altogether (which align to the Australia Post Website for the different postal zones). Everything looks fine, however, today we had a user from New Zealand go to purchase an item and when it is added to the cart and they go to check out, the shipping prices for australia are displayed. Do they have to actually create an account and logon for this to change? I would have thought simply choosing 'new zealand' from the drop down country menu would be enough to trigger the correct zone? Attached is what we have. Can anyone suggest please what we've done wrong?
  8. running this works fine: openssl s_client -CApath /etc/ssl/certs/ -connect paypal.com:443 is there anyway I can change the paypal commerce extension to reflect that URL?
  9. ok, yes, that would be good. I have found this test (to do from the server root command line) openssl s_client -connect api-3t.sandbox.paypal.com:443 -showcerts | egrep -wi "G5|return" I get an error: depth=1 C = US, O = DigiCert Inc, OU = www.digicert.com, CN = DigiCert SHA2 High Assurance Server CA verify error:num=20:unable to get local issuer certificate Verify return code: 20 (unable to get local issuer certificate) so, once that is fixed, I'm assuming I can revert to the other extension.
  10. thanks Al. Just tested that and it worked perfectly first time. I guess I'll have to fix the curl issue !!
  11. hmm, that's not good Is there another paypal extension we can try with Cubecart please?
  12. no, it is virtualmin - but I have root access to the server. we run prestashop on another of our sites with paypal check out and that works fine though?
  13. lots of stuff !! The RED errors are: Error: cURL Error (22): NSS: client certificate not found (nickname not specified) Response received (422 - Unprocessable Entity) i found your other thread about the Curl error. I've updated our server to OpenSSL 1.1.1 - which is the latest. Tried again, but still get this error in the log: Request Sent (cURL) - https://api.paypal.com/v1/identity/generate-token Error:cURL Error (22): NSS: client certificate not found (nickname not specified) Response received (400 - Bad Request) so, the response has changed from 422 to 400.
  14. thanks for the reply Al. No, there is nothing in the buyer or seller account. No activity what-so-ever ?
  15. Hi all, I'm wondering if someone can point me in the right direction here. We've setup our CubeCart shop and all seems to be going well - until we actually tried to purchase something. We've installed the Paypal ecommerce module, linked it to our paypal account and that all went well. I then go on to the website, add a product to cart, then view cart and check out using paypal. The program has me logon to paypal ok - then returns me to the payment screen, I tick the agree to terms * conditions box, then pay. I then am returned to the program with: Many thanks for your order! The order status is currently pending but it will automatically update to processing once payment is confirmed. Normally this is automated and will happen within the hour but please do contact us if you require more information. So for all intents and purposes, it has worked - however, no money ever comes out of my paypal account, nor does it go into the seller paypal account. The purchase shows up in the store 'dashboard' and I thought perhaps I have to change it from pending to processing to order complete - but nothing (as in money transfer) happens. I've not changed any of the default settings - so what could be wrong please? I've gone and disassociated the account and removed and reinstalled the extension - cleared cache, but nothing seems to work. We are using the very latest version of Cubecart, the default foundation skin and the latest paypal commerce extension.
×
×
  • Create New...