Jump to content

Cart empty


Guest ipsedpub
 Share

Recommended Posts

Guest ipsedpub

Running 3.0.7pl1, everything was fine until this evening, now when users view their cart it says "Your shopping cart is currently empty."

How can it just stop working?

Thanks for any help

Link to comment
Share on other sites

Guest ipsedpub

This seems to be the same issue as my previous post re logging in.

I think there might be a problem with Firefox and cubecart?

I need to have more of a play to provide more info but deleting all cookies has fixed it.

Link to comment
Share on other sites

  • 2 weeks later...
Guest mashurst

This seems to be the same issue as my previous post re logging in.

I think there might be a problem with Firefox and cubecart?

I need to have more of a play to provide more info but deleting all cookies has fixed it.

There are several topics out there all about the same thing. I am having the same problem.

Link to comment
Share on other sites

  • 2 weeks later...
Guest mashurst

This seems to be the same issue as my previous post re logging in.

I think there might be a problem with Firefox and cubecart?

I need to have more of a play to provide more info but deleting all cookies has fixed it.

There are several topics out there all about the same thing. I am having the same problem.

just type in "empty" into the search box and most of the posts will come up with this same problem. Unfortunately, no answer to fix it though.

-M :on2long:

Link to comment
Share on other sites

  • 5 months later...
Guest thimk

Ok, I finally got to point of enabling PP-IPN and trial order. On both IE6 and FF1.5, I get "Your shopping cart is currently empty." As Victoria Regina said, "We are not amused". Now what??????????????

Link to comment
Share on other sites

Guest bholland

I'm also running into this issue, but only on FF. If I refresh the product page it seems to take care of the issue. I have the redirect to cart mod installed, not that it should make any difference. One interesting thing is that the basket shows empty when I add the product (and am subsequently redirected to it), but my "thumbnail" cart does show the products being added. Also, when I went to just "view" the cart without adding a product to it they showed up until I went to the homepage and it cleared the contents. Once again, this only happened in FF and could be corrected with refreshing the page. There doesn't seem to be logic with why this is happening...Also, I should point out that I'm not happy with the "refresh" or "just clear your cache" type suggestions. All of this translates into lost sales and I think it is obviously a bug that needs to be looked at and corrected </end rant>

Link to comment
Share on other sites

Interesting...

Perhaps this has something to do with Firefox's vaunted page-caching abilities? If so, perhaps it could be corrected with an anti-caching meta tag in the head section. I think maybe I also want to try using a normal form link instead of that small, seemingly-unnecessary JavaScript for 'Add To Basket'...

Anyone gotten any further in debugging this issue?

Link to comment
Share on other sites

  • 2 weeks later...

OK this does NOT seem to be a Firefox issue...

I added a user-agent string to the bottom of my contact form email template, and so far the two people who have reported this problem are both using IE6 on Windows XP. Which is what I used for months while I built and tested this site, and I never once ran into this problem. This must be some sort of session corruption or something...

Has anyone figured out the cause of this critical issue yet?

Link to comment
Share on other sites

Or at least figure out what is it...

Could PHP compression have something to do with this?

Can anyone figure out a way to reliably reproduce this error so that we can track it down and kill it?

Link to comment
Share on other sites

  • 2 months later...

yup its a 12/13 nov problem as it was working fine for a few days, testing ect, and this problem broke the shared ssl fix/problem - ie: it has problems [well o my end] redirecting from ssl, from cart to logging in - then losing the cart items, and e,ptying basket ect, ecrt - and it was coping fine untill last night/today. very annoying

yes i did clear cookies/ cleare cache ect and it dosent work correctly in either, IE6, FF 1.5.07 [u know the updated one], Opera 9 and Netscape 8.1

Link to comment
Share on other sites

Add me to the list of the same odd problem happening. Actually this morning I finally got an e-mail from a annoyed customer. They would click 'Add to Cart' button, and in the little cart summary box it would actually show the item in there...but when they would actually go into the cart, it would show up as empty. :huh:

:P I need an empty cart fix!!!

Link to comment
Share on other sites

Guest vinyltrendz

not a issue for me on my computer. but i get 2-3 emails about this a week from customers saying this is happening to them on my shopping cart. UHHG!

Link to comment
Share on other sites

Guest chantesse

I have the same thing being reported today. It was a FireFox 1.0 user. When I asked if cookies were enabled or not I did not get a clear answer, and as the customer was non-technical herself, decided not to press the point. But she did say that she never gets a problem on other shopping sites.

The reported symptoms are: View the product details and click on Add to basket. The basket in the top RH corner does not show the added item.

It is a bit concerning and if common, must be reproducible eventually in a controlled setup.

Question: How many shopping sites are/are not cookie based in order to make their shopping basket work?

Link to comment
Share on other sites

This has been going on for quite a while with no clear solution and some debate over whether a problem really exists. I have multiple client stores and have gotten complaints about this since the beginning a couple of years ago. It has to do with when shopping as a Guest. Please see these posts for some background on the issue:

These first two go together. First this one:

http://www.cubecart.com/site/forums/index....showtopic=23425

Then this one:

http://www.cubecart.com/site/forums/index....showtopic=23649

And most recently:

http://www.cubecart.com/site/forums/index....showtopic=23071

As you can see, things have been a little tense between the afflicted and some of those who haven't seen the issue (yet). I am hoping it is quietly resolved with the release of 3.1.

In the mean time, I have a "Cart Problems" document on all stores giving the workarounds that I have found can stop the issue:

(1) Delete cookies and empty cache (only works occasionally)

(2) Register, log in and start over with your shopping (always works)

(3) Go to View Basket and hit the Empty Basket link even if it is already showing empty and then start shopping over again as a Guest. It will then hold the items properly even when the user registers to check out. (almost always works)

Hope this is useful to you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...