Jump to content

Cant register or buy products


Turtleman
 Share

Recommended Posts

Since I wiped the whole database and cart off the server and re-installed the Cart and Database as new I still have the same problems as I've had for the last several months..

People cant register on the cart, after filling in the required information and clicking the "submit/continue" it goes back to the same page to be filled in again,, of course any login fails with that information. Try for yourself Here

I also have the issue that both Al and Convict helped with but I haven't been able to correct the issue, and thats the Buy button doesn't add any products to the cart. I had another topic Here but I've re-installed the whole cart and have the same problem

Any helps apperciated

:dizzy:

Link to comment
Share on other sites

Well my first guess is that something was messed up when you did the skinning (very pretty site btw). I would go thru the files line by line for both viewCat.php (viewCat.inc.php as well) and cart.php and see if something was accidentally deleted or mangled when you did the skinning modifications.

Link to comment
Share on other sites

Thanks For the reply Mysty, I found the cart.php file in the root DIR.. but I dont know where to find the other two files.. (theres allot of files in this thing :( ), LOL

Once I can find them I'll put them in winmerge next to the OME files and see what I can see... not that I'll really have any idea of what I'm looking at, but I'll give it my best.

Any ideas where to find the viewCat.php and viewCat.inc.php ?

Link to comment
Share on other sites

Well cart.php from the original download is identical to the cart off the server.. I'm not sure about the other two files, but I'm guessing there in my skin folder.

edit

styleTemplates/content has the viewcat_tpl.php, but so far I still cant find the viewcat.ini.php (yet anyways) So I've found the same problem as Convict found and the "Buy" issue is resolved... but I still cant figure out why people cant register...

Link to comment
Share on other sites

Okay so I'm assuming you didn't do the modifications yourself? If not, you should discuss the problem with whoever did the modifications for you so they can look back thru what they did and perhaps figure it out easier for you.

Each file has at least a template and an include file associated with it. You need to look at all of them, not just the one in the root directory. Look at skins/yourskin/styleTemplates/global and you will find cart.tpl there. Then look at includes/content and you will find cart.inc.php there. There is also index.tpl with index.inc.php, viewCat.tpl with viewCat.inc.php, etc.

There are many other files called within the files above, so the problem could have been caused anywhere. You might try changing your store over temporarily to one of the default skins and see if you still have the problems. If so, the error was probably made in one of the include files instead of the template files. The error could be something as simple as a missing ' or something, so you will need to compare them very carefully.

Link to comment
Share on other sites

Guest chantesse

I tested your site just now in Firefox and IE 6.0 an both as you say, can't register.

Now it is behaving just like something that happened to my shop a week or two ago but only in Firefox: Forms get cleared out, browser stays on same page. Can't register as a customer. When I retested some days later, I could register again in Firefox (2.0.0.3).

See this thread where something similar was discussed - could the layout.css bit be relevant to you?

http://www.cubecart.com/site/forums/lofive...php/t25891.html

Link to comment
Share on other sites

Thank You chantesse Interesting topic, but the CSS are so far different between the download versions and the custom skin set I'd never be able to see what or were to start, I'm sure its not a layout issue because I did get the Buy button to work. It's just the registration problems I'm missing.

discuss the problem with whoever did the modifications for you so they can look back thru what they did and perhaps figure it out easier for you.

Well I left a message, but who knows....

This has gotten me totally depressed,

After about a year of waiting for a skin to match our community forums and only two simple mods on the cart I think I'm about to draw the conclusion that no matter who you hire, no one can fix anything (I can't).

Is there anyone who can de-bug a cart?

Link to comment
Share on other sites

Guest chantesse

Tested it just now Turtleman IE 6.0 and is working so you obviously had something done. Any details on how it was fixed for the benefit of those reading this thread who might have a similar error?

Link to comment
Share on other sites

I have No Idea on what Mortekai did..

But since it works I'll cancel therapy sessions, I sent Mortekai a mail so lets hope he'll pop back in and post the code changes...

Morteki does the graphics work and also host our site, I've been hosting there for a few years now.

Edit

I did get a reply but I still dont know what file he changed;

One of the formtags was not closed properly, so I pasted over the original form and

voil?? :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...