Jump to content

Martin Lines

Member
  • Posts

    23
  • Joined

  • Last visited

Martin Lines's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I am having issues with this. The first part of the installation is ok. The extension installs and then enrolls into Paypal. At the close of the paypal process there is a "return to cubecart link". Clicking on this trys to return to the store but sits there (with the rotating browser icon - Chrome) and times out with a 503 error. At this point the entire web server has gone dead, Debian 8 is still running and Apache2 still appears in the process list. [Fri Feb 14 10:17:48.819360 2020] [proxy_fcgi:error] [pid 15640] [client 86.138.104.247:59753] AH01071: Got error 'PHP message: PHP Warning: Security Warning: Illegal array key "{"authCode":"C2XXXXXXXXXX","sharedId":"AaqUNKBXXXXXXXXX-Ivaw4E","seller_nonce":"bcXXXXXXXXXXXXX3"}" was detected and was removed. in /var/www/www.bigjimny.com/public_html/store/classes/sanitize.class.php on line 114\n', referer: http://test2.bigjimny.com/store/admin_GPV8R0.php?_g=plugins&type=plugins&module=paypal_commerce [Fri Feb 14 10:22:51.208794 2020] [proxy_fcgi:error] [pid 12116] (70007)The timeout specified has expired: [client 86.138.104.247:59754] AH01075: Error dispatching request to : (polling) [Fri Feb 14 10:23:01.870226 2020] [proxy_fcgi:error] [pid 12142] (70007)The timeout specified has expired: [client 86.138.104.247:59758] AH01075: Error dispatching request to : (polling), referer: http://test2.bigjimny.com/store/admin_GPV8R0.php?_g=plugins&type=plugins&module=paypal_commerce [Fri Feb 14 10:30:21.835977 2020] [proxy_fcgi:error] [pid 12067] (70007)The timeout specified has expired: [client 86.138.104.247:60066] AH01075: Error dispatching request to : (polling) [Fri Feb 14 10:32:19.947797 2020] [proxy_fcgi:error] [pid 12117] (70007)The timeout specified has expired: [client 86.138.104.247:60095] AH01075: Error dispatching request to : (polling) [Fri Feb 14 10:32:32.071498 2020] [proxy_fcgi:error] [pid 15622] (70007)The timeout specified has expired: [client 86.138.104.247:60097] AH01075: Error dispatching request to : (polling) [Fri Feb 14 10:32:37.936452 2020] [proxy_fcgi:error] [pid 15640] (70007)The timeout specified has expired: [client 86.138.104.247:60100] AH01075: Error dispatching request to : (polling) restarting Apache2 (service apache2 restart) brings back the web server. Trying to access the extension kills the web server again
  2. I dont know, is it? It has worked fine for a number of years but since I did a clean install and database restore it has malfunctioned.
  3. PayPal Checkout Faster & More Secure Checkout 1.2.6 Plugins CubeCart Limited
  4. Looking in Request Log. Successful sales have 4 entry lines in the Request Log - all are where "Express Checkout" was used. Sales stuck at Pending have 2 entry lines which almost seem to be webpage code rather than a transaction (see below) I can manually force Paypal to re-send the IPN, I do not see any entry appear in the request log? Nothing appears in the Order history apart from a burst of multiple pending entries from the gateway. Request Sent - https://api-3t.paypal.com/nvp L_BUTTONVAR0=subtotal%3D25.20&L_BUTTONVAR1=invoice%3D200210-131312-4354&L_BUTTONVAR2=paymentaction%3Dsale&L_BUTTONVAR3=currency_code%3DGBP&L_BUTTONVAR4=buyer_email%3Dphil.ski2003%40gmail.com&L_BUTTONVAR5=first_name%3DPHILIP&L_BUTTONVAR6=last_name%3DHANSEN&L_BUTTONVAR7=address1%3D22+hillside+Eastdean&L_BUTTONVAR8=address2%3D&L_BUTTONVAR9=city%3DEastbourne&L_BUTTONVAR10=state%3D&L_BUTTONVAR11=zip%3DBN20+0HE&L_BUTTONVAR12=country%3DGB&L_BUTTONVAR13=billing_first_name%3DPHILIP&L_BUTTONVAR14=billing_last_name%3DHANSEN&L_BUTTONVAR15=billing_address1%3D22+hillside+Eastdean&L_BUTTONVAR16=billing_address2%3D&L_BUTTONVAR17=billing_city%3DEastbourne&L_BUTTONVAR18=billing_state%3D&L_BUTTONVAR19=billing_zip%3DBN20+0HE&L_BUTTONVAR20=billing_country%3DGB&L_BUTTONVAR21=showHostedThankyouPage%3Dfalse&L_BUTTONVAR22=bn%3DCubeCart_Cart_HostedProUMP_v6&L_BUTTONVAR23=template%3DtemplateD&L_BUTTONVAR24=return%3Dhttps%3A%2F%2Fwww.bigjimny.com%2Fstore2%2Findex.php%3F_a%3Dcomplete&L_BUTTONVAR25=cancel_return%3Dhttps%3A%2F%2Fwww.bigjimny.com%2Fstore2%2Findex.php%3F_a%3Dgateway&L_BUTTONVAR26=notify_url%3Dhttps%3A%2F%2Fwww.bigjimny.com%2Fstore2%2Findex.php%3F_g%3Drm%26type%3Dplugins%26cmd%3Dcall%26module%3DPayPal_Pro&BUTTONCODE=TOKEN&BUTTONTYPE=PAYMENT&METHOD=BMCreateButton&VERSION=112&PWD=8S39498232UY88DY&USER=bigjimny_api1.lines-family.com&SIGNATURE=A-vOW1cL7HT4gPOihcEcJAuy3CRzA3xHQ8yujybW-bBnui4J70Z9VXps Response received WEBSITECODE=%3cform%20action%3d%22https%3a%2f%2fsecurepayments%2epaypal%2ecom%2fwebapps%2fHostedSoleSolutionApp%2fwebflow%2fsparta%2fhostedSoleSolutionProcess%22%20method%3d%22post%22%3e%0a%3cinput%20type%3d%22hidden%22%20name%3d%22hosted_button_id%22%20value%3d%22HSSS%2d0UJYhSjiKg3t92IpFDajWYCHUhD3yXoVCCj7nmfOSAogvzBWPl10luVKFlD6D2b98rgb0A%22%3e%0a%3cinput%20type%3d%22image%22%20src%3d%22https%3a%2f%2fwww%2epaypalobjects%2ecom%2fen_GB%2fi%2fbtn%2fbtn_paynow_LG%2egif%22%20border%3d%220%22%20name%3d%22submit%22%20alt%3d%22PayPal%20%e2%80%93%20The%20safer%2c%20easier%20way%20to%20pay%20online%21%22%3e%0a%3cimg%20alt%3d%22%22%20border%3d%220%22%20src%3d%22https%3a%2f%2fwww%2epaypalobjects%2ecom%2fen_GB%2fi%2fscr%2fpixel%2egif%22%20width%3d%221%22%20height%3d%221%22%3e%0a%3c%2fform%3e%0a&EMAILLINK=https%3a%2f%2fsecurepayments%2epaypal%2ecom%2fwebapps%2fHostedSoleSolutionApp%2fwebflow%2fsparta%2fhostedSoleSolutionProcess%3fhosted_button_id%3dHSSS%2d0UJYhSjiKg3t92IpFDajWYCHUhD3yXoVCCj7nmfOSAogvzBWPl10luVKFlD6D2b98rgb0A&HOSTEDBUTTONID=HSSS%2d0UJYhSjiKg3t92IpFDajWYCHUhD3yXoVCCj7nmfOSAogvzBWPl10luVKFlD6D2b98rgb0A&TIMESTAMP=2020%2d02%2d10T13%3a13%3a24Z&CORRELATIONID=46449e8f1521d&ACK=Success&VERSION=112&BUILD=53816562
  5. I recently upgraded to 6.2.8. I had to do a clean install and then bring back in the database etc. Since then, IPN from Paypal has not worked. I can look in Paypal and can see the IPN is sent OK and can see the "200" response recorded both in Paypal and in the Apache log on my server. However the transaction stays at "pending" in cubecart There are no errors in the Cubecart error log (apart from Timezone errors) How can I track further where it is failing?
  6. I would like to say it works really well for me but looks like something was broken in some recent update (it is well maintained). Still at least I found the issue and realise that the webmin interface can hide error messages
  7. It did say it was complete. However I have just found the issue. I use "webmin" to access the server and something has changed in it that means it does not force the over-write of some files but the error messages are not displayed on the interface. I have just gone directly into bash and run unzip with sudo and put in the -o flag and it has just worked ok. Webmin worked fine up to around the time of 6.1.10 so something has changed there.
  8. I have had to manually upgrade for 6.1.09 to .10 to .11 and now to .12 This is because I get a long list of "Content after extract doesn't match source" messages using the automatic process. However, the manual process seems to work (the files copy ok and then setup runs with any errors) BUT I still get "WARNING: Your store is not up-to-date, v6.1.12 is available, but you are running v6.1.10" messages on the admin home page?
  9. AH - I have upgraded to PHP 7 inbetween cubecart releases and needed the ziparchive module installing!
  10. My is also failing to upgrade log is showing [Exception] /var/www/www.bigjimny.com/public_html/store/admin_XXXXX/sources/maintenance.index.inc.php:203 - Class 'ZipArchive' not found
  11. Yes - its the Ebay_Sales plugin which uses Ioncube Martin
  12. Ian, Thanks, the certificate problem is because this is a copy of my live system running on a test server so the URL does not match the certificate. Thanks for the pointer to APC, I have added in APC support to the PHP7 instance but it doesnt seem to be working. If I edit the global.inc file to remove caching I then move onto an ioncube issue Thanks Martin
  13. As per title, does cubecart support php7? I have a test site running php7 (https://test.bigjimny.com/store) and it is not running for me but before I go away and start looking I need to ask if it is supposed to work? Martin
  14. The table is there cubecart.cart_CubeCart_option_matrix 25 MyISAM utf8_unicode_ci 5.56K -
  15. I have deleted them and re-added through the New Option dropdown. During the deletion process I got a pop-up box with the word "undefined" in it. When I added them no Option Matrix appeared. I then deleted each individually and a pop-up box with the word "undefined" came up again on each deletion
×
×
  • Create New...