Jump to content

Index_enc_ion.php Problem


KirkM
 Share

Recommended Posts

I did a fresh install of 4.1.1 and all looks good except that the slug page that is up when the store is off has a Warning on it:

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/nasports.com/httpdocs/store/index_enc_ion.php on line 52

Got all green lights on compat-test.php and encoder is set to ioncube. I also re-uploaded every relevant file in binary.

You can see for yourself at www.nasports.com/store

Thanks for any help on this.

Link to comment
Share on other sites

Well your PHP is outdated. PHP 4 >= 4.3.0 is required as stated at CubeCart homepage

I am sorry the compatibility script should be updated.

Where did you get that?

Actually, I'm running 5.2.5 so that isn't it. I also have another store V 4.1.1 on the same server and it works fine.

www.anabol.com

If you do www.nasports.com/store/compat-test.php you will get this:

CubeCart 4 Requirements Test

Ioncube Loader: Installed

Zend Optimizer: Not Available

GD Image Library: Version 2

PHP ≥ 4.3.0: 5.2.5

MySQL ≥ 4.1.0: 4.1.22

Congratulations.

Your server is compatible with CubeCart v4

If all tests have a green result on the right, then your server should run CubeCart 4 without any problems.

Link to comment
Share on other sites

Guest Brivtech

Actually, I'm running 5.2.5 so that isn't it. I also have another store V 4.1.1 on the same server and it works fine....

... PHP ≥ 4.3.0: 5.2.5

Actually, you may find that it is: if your server looks like it supports dual php versions (There are 2 versions listed), and in this case, it may be set to the default of version 4 php. In order to get it working with php5 in this instance, you'll need to do a small .HTACCESS hack, to tell the server to use php5 as the default, and php4 as the exception. Your hosting company will be able to tell you what to do here.

I can't help thinking that you may need a different version of the ioncube loader. When you say you have another working store on the same server, do you mean the exact same server, with the same domain?

Link to comment
Share on other sites

Actually, I'm running 5.2.5 so that isn't it. I also have another store V 4.1.1 on the same server and it works fine....

... PHP ≥ 4.3.0: 5.2.5

Actually, you may find that it is: if your server looks like it supports dual php versions (There are 2 versions listed), and in this case, it may be set to the default of version 4 php. In order to get it working with php5 in this instance, you'll need to do a small .HTACCESS hack, to tell the server to use php5 as the default, and php4 as the exception. Your hosting company will be able to tell you what to do here.

I can't help thinking that you may need a different version of the ioncube loader. When you say you have another working store on the same server, do you mean the exact same server, with the same domain?

No, I mean www.anabol.com domain on the same server. Where do you see 2 versions of php listed? I've been running php 5.x for quite a while now and don't see any evidence of php 4 anywhere. The line "... PHP ≥ 4.3.0: 5.2.5" is from compat-test.php output meaning "is you php 4.3 or above: it is 5.2.5" I see no evidence of php 4 running on this box.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...