Jump to content

Currency and language in front store


Guest Fernando Santos
 Share

Recommended Posts

Guest Fernando Santos

Hello,

My website is www.shop.reefset.com. CC 5.1.5

My default language is Portuguese, when i try to change to another language in front store the flag simply don´t work. some times at first time works, if you try to go back to previous language, nothing happens. Same situation with currency.

One thing i noticed, if i click in flag and then refresh my browser the changes work.

Any help??

Thank you

Link to comment
Share on other sites

Interesting. Although a language filename of xx.xml is legal, it seems there is a difference of action as compared to a language filename of xx-YY.xml

Allow me to suggest renaming the language filename to pt-PT.xml and making the same edits to the statements in that file.

Meanwhile, I'll add this strangeness to my list of things to look at.

Have you made any other edits to the code?

Link to comment
Share on other sites

And the currency behaves strangely. I wonder if this has something to do with the fact that both www.shop. and shop. both work as a subdomain.

If you wish, you can turn on debugging in the admin (Store Settings, Advanced, Performace Group, Enable Debugging.

Also, if you wish, you can restrict showing the debugging info to just the IP addresses you list. If you want to do that, send me a PM and I will give you my IP address.

Link to comment
Share on other sites

Guest Fernando Santos

I have changed the xml file to pt-PT and then to pt.xml, same problema exist. I think currency has nothing to do with language, And seems to have the same problem.

Link to comment
Share on other sites

Guest Fernando Santos

Interesting. Although a language filename of xx.xml is legal, it seems there is a difference of action as compared to a language filename of xx-YY.xml

Allow me to suggest renaming the language filename to pt-PT.xml and making the same edits to the statements in that file.

Meanwhile, I'll add this strangeness to my list of things to look at.

Have you made any other edits to the code?

I already sent a PM few days ago. have you seen it?

Link to comment
Share on other sites

Guest Fernando Santos

As I write this, your store is not displaying the language or currency selector. Did you make edits in the skin file to cause this? Or, more likely, disable all the currencies and languages so that there would be no selector to use?

Yes, I disable the currency and language, but now they are open again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...