Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest fiddy

3.0.1 | Worldpay | confirmed.php.. Working?

Recommended Posts

Here, I rekon this will fix it...

includes/content/confirmed.inc.php

Attachment removed... see next post. Sorry!

Share this post


Link to post
Share on other sites

Guest benseb

haha ready for this....

it shows up errors, then seems to redirect or something and then looks fine?

try it..

http://www.skiddle.com/shop2

don't worry its in test mode

you can use the visa card number 4000 0000 0000 0002

with any future expiry date

Share this post


Link to post
Share on other sites
Guest benseb

ang on just seen the new attachement

give me 5

Share this post


Link to post
Share on other sites
Guest benseb

yeah same thing. managed to catch the error..

then it dissappears and loads the correct thanks page

Share this post


Link to post
Share on other sites
Guest fiddy

your virus checker is out of date BTW :P

Share this post


Link to post
Share on other sites

it shows up errors, then seems to redirect or something and then looks fine?

That post was REALLY helpful!

As a result here is the full working code :P

WorldPay_4.zip

Share this post


Link to post
Share on other sites

your virus checker is out of date BTW :P

That or he hasn't installed the latest win updates yet... Double click the yellow shield and see what it says.

Share this post


Link to post
Share on other sites
Guest benseb

updates pending... they p*ss me right off asking me to restart my pc in the middle of the day

bloody microsoft

Share this post


Link to post
Share on other sites

My laptop keeps blue screening as if I play some good music I beat it like a drum.

Bound to loose some work some day soon...

Share this post


Link to post
Share on other sites
Guest benseb

aha

I think its working

it comes up with a blank page with http://www.skiddle.com/shop2 at the top

then redirects to the shop, all looks good there

give it a test yourself if you like using the details on the previous post?

looks good - well done!

Share this post


Link to post
Share on other sites

Thats how it should work. :P

It is the only work around I could find and Authorize.net works in the same way. Pleased it is working and even moreso I'm pleased you use the affiliate module as that helped the development even more.

Share this post


Link to post
Share on other sites
Guest benseb

do your beta testers get any perks? :P

Share this post


Link to post
Share on other sites

Yeah of course! How's a working store sound? :P

Nobody elses works!?! Joke.

Sincerest thanks to you all! :)

Share this post


Link to post
Share on other sites
Guest fiddy

hmm. Installed v4 files, changed WP to 'use callback response'

go through purchase no problem, shop > WP fine, WP back to shop seems to work from the customer pov, i.e. the CC shop says thankyou, order successfull, please come back soon, or words to that effect

but, the order remains at 'pending'. I though this should change to processing, and the order email should get sent to the customer confirming the order? no?

Share this post


Link to post
Share on other sites

It should work like that yes.

Back to the drawing board...

Ben, did you have this too or did it work?

Share this post


Link to post
Share on other sites
Guest fiddy

by all means fiddle on my server mate. All set up with the correct WP callback settings etc now.

Share this post


Link to post
Share on other sites

Doh! I forgot to change the variable name in ../WorldPay/confirmed.inc.php

It was looking for a variable Authorize.net would send.

100% Happy the archive below is the final version. :unsure:

WorldPay_5.zip

Share this post


Link to post
Share on other sites
Guest fiddy

tsk, muppet. school boy error :unsure:

upload and test it if you like, I can't ftp from here.

Share this post


Link to post
Share on other sites

The FTP access you gave me wont work: (xxx is edited domain of course)

    SmartFTP v1.5.988.20

    Resolving host name "xxxxx.dedicated.xxxx.co.uk"

    Connecting to xx.xx.xx.xx Port: 21

    Connected to xxxxx.dedicated.xxxxx.co.uk.

    An established connection was aborted by the software in your host machine.

    Server closed connection

    Cannot login waiting to retry (30s)...

Share this post


Link to post
Share on other sites
Guest fiddy

you've got your ftp sw on secureftp ports etc still? (you've left the ip addy in above btw. tsk)

Share this post


Link to post
Share on other sites

×
×
  • Create New...