Jump to content

bos

Member
  • Posts

    83
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by bos

  1. What's the difference of these two? In my setup, is Status is checked and Available for purchase unchecked, users can buy the item. If status is unchecked, then it does not matter what Available is, the item is not available for purchase.
  2. That was a typo. It should have been UNavailable (I have edited the post). The web hosters I've been using are One.com (current), Loopia (previous), and Crystone (former). None of them supports or allows ionCube.
  3. I started using Cubecart some years ago, but I never became good friend with the tax system so it applies to my shop exactly how I want it. Trial and error during long periods showed me that the system is really simple; all costs entered are without VAT. But what I want is that all costs entered should be including VAT, and that in the summary the VAT should be shown as a value /of/ the total, not adding to the tutorial. Someone suggested to use a tax extension from Noodleman that would let me do what I want, but alas: that extension (as well as a lot of others) uses an apache extension called ionCube, which has been and is UNavailable on all the three web hostings I've tried, and it's not installable per user. So, I was at a loss. The workaround for my problem was to let Cubecart ignore anything that had to do with taxes, make enter all costs as including VAT. Then, in the order summary, I manually calculated the tax (total value * 0.2) and entered in the tax field. That way everything was correct and exactly how I wanted it. Total sum including tax, and the tax value being the tax value /only/, without adding or substracting itself to anything. The backside of this approach is that it's been tedious work as my shop has grown bigger. So after 1 year of manually adding the taxes I took a dive into the source code to see if I could make some patch (for my own use only). I ended up changing this file: admin/sources/orders.index.inc.php: (add near line 425) $overview_summary['total_tax'] = Tax::getInstance()->priceFormat($overview_summary['total'] * 0.2); This made Cubecart automatically fill the taxes box in the summary page for the order, without touching anything else. However, this had a side effect: in the print out, the tax field was not in the same format as the other monetary values. Instead of "123.00kr" it would be "123". No decimals and no currency. A quick and ugly "solution" to this was changing the template: admin/sources/orders.index.inc.php: (near line 219) <!-- div class="total">{$tax.name} <strong>{$tax.value}</strong></div --> <div class="total">{$tax.name} <strong>{$order.total * 0.2}kr</strong></div > <!-- bos 2019-12-31, auto tax --> This works, sort of, if the currency is SEK (kr, kronor). Rounding errors can occur, leading to "123.4567kr" and so forth, and it will be totally bogus when a customer uses another currency. I did however not find a way to make an inline PHP-call to number_format(), or to Cubecart's internal currency/number-function (which I do not remember the name of at this time), but all in all these small changes saves me tons of work by not having to enter the tax sum manually. (NB: Should this post be in the wrong forum I will humbly apologize. I picked it since it was the one that best fit the description) EDIT: Typo
  4. Seems like it (I switched host provider). Upgrading to CC 6.2.8 seems to have solved this problem. Thanks.
  5. I'm unsure if I should bug report this on github or here, so I try here first. On https://github.com/cubecart/v6, under "Upgrading from v6 to v6", there is a link to https://support.cubecart.com/Knowledgebase/Article/View/228/43/how-do-i-upgrade-from-cubecart-v6-to-latest-v6. Clicking this link gives "The page you were looking for doesn't exist" as a result. Googling that document also gives a link that's 404.
  6. I'm not sure if this is a bug or if it is I who's ignorant, but after I switched to SSL last month I did not test promotional codes until today, and somehow they don't seem to work. If this is a bug I will add it to github. As for the promotional codes: I fill all values as before (before SSL), and when saving the code itself is gone. All the values are there, but the code is null (see attached screenshots). Opening phpMyAdmin and editing the line in question, the code got back. I tested it on an order and got this message: The following errors were detected: Den kupongen existerar tyvärr inte. (That coupon does not exist) So, ok; maybe there's more mechanics behind the scenes than just updating the code word in the db, so I searched for an active - but still unused - promotional code and tested with that one, and got exactly the same error message! Editing an existing code, changing the code name, does not save the new code name. EDIT: the second screenshot says "Promotional code deleted" in the top header. It is irrelevant to this problem (I deleted another code just prior making the screenshot). Sorry for the confusion.
  7. As above. Is this possible in CC 6.2.5? Background: more than once the same user(s) have registered multiple accounts (same shipping address, only email address is changed). This was not a problem in the beginning, but it's starting to be.
  8. When going to the store front, there's a sidebar containing "Recommended product(s)", which I surmise is just a random product shower based on something. I just had this idea that it would be nice to be able to link / show specific products together, but I haven't found out if it's possible to do (with or without an extension). Example. Let's say I sell two products: a complete faucet, and separate valves (spare parts). These two products are sold separately, but for the case when someone buys a faucet, I would like to link the valves to it, so when browsing the product page for faucets, a potential buyer will see this "recommended product: Gold-plated Valves" in a box nearby. An option matrix does not apply here since these are two separate products, but I think adding the possibility for links/recommends would be nice. Is it possible to do this in CC 6?
  9. Does this work in CC 6.2? When I try to install it, it works, but when I try to edit it I only get this message: Since my store is located at a Web hosting service I cannot install this "ionCube".
  10. I can now confirm that you are correct, and that the actual culprit is the category name. I have a category named "Kablar", which is "Cables" in English (the translation exists). Using English for the administrator, I added a test product and selected the Cables-category. The SEO-path became "cables/test", which is not what I want. I want the Swedish names for all paths. In this case, "kablar/test". I can understand why the English category name was chosen, but I'm not very fond of it. The simple solution would be to get rid of dual languanges, but that - I surmise - will affect which kind of customers shows up in my store. Another possibility is perhaps to remove all admin-related translations from the Swedish language-file. That way, I can keep English for the admin panels, while customers still get the Swedish version in the store.
  11. I run a Cubecart-store in Swedish; all products and categories are in Swedish. On occation, some products and categories also have an English translation. Recently I found a strange thing, when I switched the superuser-account to English and used the admin panel to add a new product (that has a translation); the SEO-path for that product appears in English. If I switch back to Swedish and re-add a new product, the SEO-path appears in Swedish. If I switch back to English again and browse to the product, the SEO-path is still in Swedish (which is what I want). However, I would prefer that all SEO-paths are in Swedish, no matter which language I use in the admin panel. I peeked around under the Search Engines tab, but found no obvious setting for this. Is it possible to enforce SEO-paths to always use Swedish?
  12. I just tried sending a message using the "Contact us" button, and the mail appeared the same. I.e. the text I entered was replaced with "-----". Sounds like a bug to me. Are the messages stored somewhere under the admin interface?
  13. I received a mail from my store, with contents almost looking like a customer trying to get my attention, but without the actual attention. Did s/he sent a message? Where can I find it?
  14. I was about to backup. DB-backup worked fine, but when doing file-backup this message appears: I went to Error Log to see if anything landed there, but both Admin and System logs are cleared (or not logged at all). CC 6.1.7.
  15. The errors have returned after a few upgrades. Thankfully the email test atleast shows some information this time: I have not touched anything since the last time I got it working, and the test log is rather scarce. Any ideas? Mail seems to work with "PHP mail()", but not with "SMTP with TLS" (or SSL).
  16. bos

    CC6 + PHP7

    My web provider is on the verge upgrading their farms to PHP7. I can opt in or out this for my particular site, but in the long run I will be forced to upgrade. Question: Does CubeCart 6 run on PHP7 out of the box, or does it require some special care? I do not have administrator rights at my web provider.
  17. CC6, as the tag suggests. Same quirk arises even if I select "Registered customer".
  18. Sometimes customers are lazy and "have no time to create an account", but since I want revenue I gladly help them. Customer List -> Add new customer, add the name, "Unregistered customer" and Save. Done. Then heading to "Address book", add new address, and the customer name - again - before saving. The name is a required field, too. Why? What's the purpose of forcing me to type the name twice?
  19. One product have two options: assembled (+X increased cost) and kit (0 increased cost). This works as expected. Now, this product comes in two colors; red and blue. The price is the same for both colors, i.e. nothing in the store (stock, cost, etc) is changed. Except for the physical color. But, I can't get this option combo to work. In option groups, I have "Color" (radio button) with Red/Blue as option attributes. I also have "Assembled" (dropdown list) with Assembled/KIT as option attributes. All options are enabled. The "Assembled" group shows up in the object description, "Color" does not. I also tried to make an Option Matrix of the four combinations, to no avail. Question 1: How do I get these two option groups to work? The "Assembled" group is mandatory, i.e. the user has to select (and this works). The "Color" group should be optional, using "Red" as default. Question 2: If I change a text or anything in the options, the change is not reflected immediately when I refresh my browser. Even a network refresh (shift+F5) does not get the updated text. In fact, sometimes it takes several minutes for changes to appear, if they ever do. Why is this?
  20. The format is "Postal code (space) City name". The code is exactly and always five numbers, grouped 3 and 2. I.e. "ABC DE", not "AB CDE" or something else. There are a few customers outside Sweden, and to be honest; I don't care how the address format is from their point of view. My biggest concern so far is when I'm printing the address labels. Since they're all in UK-format, I've had to cut and paste and edit them all prior printing, and that's tedious work. I will take a peek on the skin templates and see what I can poke around with. Thanks.
  21. Swedish addresses use three lines: #1: Name + Surname #2: Street address, house number, apartment number (etc) #3: PostalCode City And that's it. We don't use states, counties or the like. That information is encoded in the postal code.
  22. For some of my products, the customers can choose whether they want a kit (to build themselves), or a pre-assembled device. Adding options for this was very straight forward, but I fail to see anywhere where I can use translated strings for the options. "Färdigbyggd" and "Byggsats" makes perfect sense to Swedish persons, but for non-Swedish those words are probably gibberish. How can I use localized product options?
  23. I must have become blind, because the only thing matching "templates" in the admin pages is "Email templates". Also searched under Admin -> Store Settings too, but to no avail.
  24. The standard address format in CC6 seems to be conforming to UK standard. This gets a bit messed up when using Swedish addresses. See the attached image. The correct Swedish address format using the values in the image should be: Where can I change these settings?
  25. bos

    Paypal fee

    Most things I sell in my store are things I design / create / build myself. There's not much margin on each creation, and having that already small margin eaten up by a fee not set by me is a tad sad. The option - which is really not an option - would be to increase the price for all items in the store. For me, this is not a question of moral, it's more a question of surviving the margins.
×
×
  • Create New...