Jump to content

Blank email sent to customer on order


Guest ipsedpub
 Share

Recommended Posts

Guest ipsedpub

My client uses worldpay.

When an order is taken via worldpay and the payment goes through the status changes from pending to processing.

This change in status sends an email to the customer with their order number as the subject but the email has no content.

Has this been submitted as a bug?

Are other worldpay users ok with this or as unhappy as my client?

How do I get this resolved?

thanks

Link to comment
Share on other sites

Guest ipsedpub

I have also noticed that when the status of an order changes the cart doesn't include any order details.

We therefore have the situation whereby the payment processor (worldpay) doesn't send the order details and neither does the cart. (Unless of course admin manually puts the prder details in when completing the order status).

Checking cubecart 2 I see that it has always been like this. I am surprised that it is apparently acceptable to users of this cart to send blank emails and order staus change emails to customers without including any order details.

This causing my client to get calls from customers querying their orders and in turn he is hassling me.

Is this just a worldpay issue or are other payment processors dealt with likewise?

Link to comment
Share on other sites

I too have had problems with customers receiving blank emails after placing an order through the worldpay gateway.

This is very confusing to them, as gives them no confirmation of what is happening, what they have ordered etc, just a blank e-mail which causes more concern than no email at all, raising questions and concerns.

I did raise this as an error, but nothing seems to have been done about it yet, please someone look at this as I am sure it is easily fixable.

Link to comment
Share on other sites

Guest timecrisis

I agree with all of the above.

Blank emails to customers is a serious problem.

It doesn't need a explaining why!

It seems to be a non issue when using PayPal with IPN to update the payment status.

This appears to be only when using Worldpay as a gateway.

Is the issue to do with the gateway module itself?

Can a coder please let us know what the deal is so that we can pay to get it fixed?!

I am running 3.0.6

Should we all apply Sir's 3.0.5 fix?

:)

Link to comment
Share on other sites

I am running 3.0.6

Should we all apply Sir's 3.0.5 fix?

No need to apply Sir's patch as it is included in 3.06 <_<

Just in case you can check in language/en/lang.inc.php

Search to find

END: Added in 3.0.6 by Sir William

If you find this then it has been added.

Sorry i cant help you more on your problem. :w00t:

Link to comment
Share on other sites

Guest timecrisis

Hi Vrakas,

I have 3.0.6 running and the "Sir William" text is there in my lang file.

I believe this is a Worldpay specific issue but need more info...

Thanks for your post =)

Anyone else got info on this/ experiencing the same problem?

Link to comment
Share on other sites

Guest timecrisis

Well both of these are closed...

One refers to 3.0.3 and the other 3.0.5...

I have started a support ticket...i guess I will find out from what the gods above what is going on...

Link to comment
Share on other sites

Okay - I hva manged to fix the problem ..... seeing as nonoe else was doing anything about it i had a play and found that I could fix it by making small changes to the worldpay gateway files.

1. edit modules/gateway/WorldPay/transfer.inc.php

find this bit of code: (its the final line in 3.0.6)

$stateUpdate = FALSE;

and change to:

$stateUpdate = TRUE;

2. edit modules/gateway/WorldPay/confirmed.php

find this bit of code: (line 72)

$cart_order_id = $_POST['MC_OID'];

include_once("../../../includes/orderSuccess.inc.php");

$result = "?pg=".base64_encode("WorldPay");

and change to:

//$cart_order_id = $_POST['MC_OID'];

include_once("../../../includes/orderSuccess.inc.php");

$result = "?pg=".base64_encode("WorldPay");

simplay add "//" at the start of the first line to comment out the code which was causing the blank email.

When an order is succesfull the order status should change to "processing" AND customer should now get a confirmation email with order details. if the order is declined by worldpay, the order will stay as "Pending", untill they pay for it with another card for instance...

Let me know what you think - worked for me......

:)

Link to comment
Share on other sites

Guest ipsedpub

Trees, thank you so much. Your fix works a treat.

The email notification on this cart seems to be a bit of a pigs ear. It's a bloody good job people like you can help out because there seems to be little in the way of developer acknowledgement for these issues.

I realise that support costs money but these email issues are going on and on without much if any interest from the developer. I for one would like to see him/her at least acknowledge these issues before I am happy to pay for a licence.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...