Jump to content
Paleo

404 error at index page

Recommended Posts

I'm not sure why, but some customers are hitting a 404 page not found error at the index page.

The link is popping up as:

/index.php?_a=404

 

Request logs and error logs inside the cubecart inerface are clear. Any way to find out what is causing this?

Share this post


Link to post
Share on other sites

Store also seems to be loading extraordinarily slow.

Just had a customer message me and say they couldn't get the store to load, and once loaded,  couldn't get an order to go through...

Error logs and request logs are still empty. Not sure what to do.

Share this post


Link to post
Share on other sites

Tried to submit my sitemap to google, and it gave me the error:

General HTTP error: 404 not found
HTTP Error: 404

Share this post


Link to post
Share on other sites

Customer just sent me this.

This is how the site is loading on an iPhone...

14012.jpeg

DB I sent you the url in a message.

Share this post


Link to post
Share on other sites

Your store looks OK on FireFox for me. But my browsers already have the correct javascript, etc. These are repeat customers who are having issues? If so, there's a good chance the problem IS with their browsers already having cached copies of some of the files that have changed.

Try the fix Bsandall suggested to force a Customer Refresh and see if it works.

I'll test your store on some more browsers and screen sizes to see what I get there.

Share this post


Link to post
Share on other sites

Another possibility - I see that you have a Minimaliser skin. Perhaps there are skin changes that need to be made to bring your skin up to 6.1.5? Whatever changes the upgrade would have made to Foundation will NOT have been made to your skin.

Your site works properly for me on Chrome, Microsoft Edge (new IE), and FF. I don't have a smart phone to test it on, but the Responsive tool on FF works properly at small screen width.

Share this post


Link to post
Share on other sites

I've forgotten what you upgraded FROM. - I will TRY to make a file difference list for your skin once I know what you upgraded from. from 6.1.1 to 6.1.5.

Not as easy to do as I had expected, because there is a copyright year change that affects every skin file - so they are ALL different UGH. There are some NEW files in the skin templates, too.

Maybe contacting the Minimaliser developer would be the right thing to do.

You could temporarily use the stock Foundation skin, if you just HAVE to.

Share this post


Link to post
Share on other sites

content.404.php in the templates files is one of the new files your version of Minimaliser would not have. The other new files have to do with Advanced Search, and would require skin changes to call them anyway. Add that 404 file in your skin templates folder. I don't know if adding it will be enough of a patch to keep you limping along until the right person comes along to help.

Share this post


Link to post
Share on other sites

I do everything on mobile, and I know it works with android. IPhone seems to be the bigger issue at the moment, and sometimes desktop.

(I can't get it to fail on my phone or the android phone of others, chrome, Firefox, nothing.)

 

Do you think changing skins will help? Couldn't hurt, I wouldn't think.

Share this post


Link to post
Share on other sites

You can always change back. You'll just have to clear all your cache for CC and browser. There are image changes in 6.1.5, so you may have to clear that, too - not sure about that. It's not product image changes so much as it is CC provided images.

If you've made skin edits to Minimaliser you will lose those edits with Foundation, but if you changed back to your Minimaliser skin the edits will still be there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...