Jump to content

Information Links Not Working


pcarr614
 Share

Recommended Posts

Since you haven't loaded your store with any product as yet, we will recommend that you fetch CC6.1.13 and unzip it locally on your desktop.

Rename the admin folder to what you already have on your site, rename the admin.php file to what you already have, then FTP the whole thing to your site instructing the FTP program to overwrite all existing files.

Then run /setup/index.php opting for the "Upgrade" procedure.

Other than that, what I see is that the .htaccess file could be missing, misconfigured, or out-of-date.

Here is the current essential contents of .htaccess:

##### START CubeCart .htaccess #####

### File Security ###
<FilesMatch "\.(htaccess)$">
  Order Allow,Deny
  Deny from all
</FilesMatch>

### Apache directory listing rules ###
DirectoryIndex index.php index.htm index.html
IndexIgnore *

### Rewrite rules for SEO functionality ###
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase / 
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]
</IfModule>

### Default store 404 page ###
ErrorDocument 404 /index.php

## Override default 404 error document for missing page resources ##
<FilesMatch "\.(gif|jpe?g|png|ico|css|js|svg)$">
  ErrorDocument 404 "<html></html>
</FilesMatch>
##### END CubeCart .htaccess #####

Note that the directive to send a 404 response document is the index.php page. When getting the index.php page for any and all .html pages tells me that URL rewrite capability is not enabled.

It is very important that your web server (nginx/1.12.2) be able to rewrite URLs. Check with your hosting provider (or server admin) to verify this.

Link to comment
Share on other sites

Did a fresh install of 6.1.13 same issue

Ok I figured it out. I had a previous install of WordPress on that server so the information for that install was in the .htaccess file. So I removed it and everything is working. Thanks for pointing me in the right direction.

Edited by pcarr614
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...