Jump to content

Blank Screen on setup while installing 5.2.14


snayle
 Share

Recommended Posts

Hi all,

 

I'm having a problem installing the latest version (5.2.14) of cubcart on my hosted system.

 

I have extracted and uploaded all files into a "shop" folder on through FTP and set 777 permission on following folder (without including subfolders)
cache/
files/
images/cache/
images/logos/
images/source/
includes/
includes/extra/

 

As I went to the URL of my site's /shop folder I got redirected to /shop/setup/index.php. All I find there is a blank white page.

 

I read through a couple of topics in this forum and checked my PHP version along with the availabiity of Zend Optimizer and IonCubeLoader.

Referring to the info.php I have following settings:

--

PHP Version 5.2.17
PHP API     20041225
PHP Extension     20060613
Zend Extension     220060519
Zend Memory Manager     enabled
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright © 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.5.2, Copyright © 2002-2014, by ionCube Ltd., and
    with Zend Extension Manager v1.2.2, Copyright © 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.9, Copyright © 1998-2009, by Zend Technologies
--
PHP Core
report_zend_debug    On
zend.ze1_compatibility_mode    Off
--
Zend Optimizer
Optimization Pass 1     enabled
Optimization Pass 2     enabled
Optimization Pass 3     enabled
Optimization Pass 4     enabled
Optimization Pass 9     enabled
Zend Loader     enabled
License Path     no value
Obfuscation level     3
--
Additional Modules
Module Name
ionCube Loader
--

 

Does anyone have a hint what to do?

 

Thanks

Link to comment
Share on other sites

Thank you Al

 

Here's the errors I'm getting now on the screen:

---

Warning: register_globals are enabled. It is highly recommended that you disable this in your PHP configuration, as it is a large security hole, and may wreak havoc. in / *** / ***/ *** /html/shop/classes/debug.class.php on line 156

Warning: mysqli::mysqli() [mysqli.mysqli.php]: (28000/1045): Access denied for user 'wwwrun'@'localhost' (using password: NO) in / *** / *** / *** /html/shop/classes/db/mysqli.class.php on line 22

Warning: mysqli::mysqli() [mysqli.mysqli.php]: (28000/1045): Access denied for user 'wwwrun'@'localhost' (using password: NO) in / *** / *** / ***/html/shop/classes/db/mysqli.class.php on line 22

Fatal error: Access denied for user 'wwwrun'@'localhost' (using password: NO) in / ***/ *** / *** /html/shop/classes/db/mysqli.class.php on line 24

---

I went to /includes/global.inc.php-dist and set the global variables for dbdatabase, dbusername and dbpassword to match my mySQL database.

 

After refreshing the site, I'm still getting the same error "Access denied for user 'wwwrun'@'localhost' (using password: NO)"

Link to comment
Share on other sites

 

This it the important one;

Access denied for user 'wwwrun'@'localhost'

Yes.

I set the variable for dbdatabase, dbusername and dbpassword in /includes/global.inc.php-dist. Unfortunatelly it seem's like that does not take any effect.

 

Any suggestions or hints where or how I can tell the cubecart installation which credentials to use for the database connection?

Link to comment
Share on other sites

Wrong file. It needs to be named  /includes/global.inc.php

 

I have now copied the file /includes/global.inc.php-dist to /includes/global.inc.php. Still receiving the above errors with wrong database username. :(

Link to comment
Share on other sites

"I got redirected to /shop/setup/index.php. All I find there is a blank white page."

 

For a fresh copy of the code on the site? Not an upgrade?

 

The first page of the setup process shouldn't be attempting to access the database at all. It wouldn't know where the database is.

 

What I think is happening is that the Debugger class is creating a custom error_handler for PHP, then testing for a few things. If an error needs to be reported, the custom error handler also wants to post that to the database. But the database doesn't exist as yet.

 

In the file /classes/debug.class.php, at the end, please try this edit:

Was:
  private function _writeErrorLog($message) {
    Database::getInstance()->insert('CubeCart_system_error_log', array('message' => $message, 'time' => time()));
  }
}
 
Now:
  private function _writeErrorLog($message) {
    global $glob;
    if(isset($glob['dbdatabase']) || isset($GLOBALS['db'])) Database::getInstance()->insert('CubeCart_system_error_log', array('message' => $message, 'time' => time()));
  }
}

I haven't tested this as yet. But this should write to the database only if CubeCart knows about the database.

Link to comment
Share on other sites

"I got redirected to /shop/setup/index.php. All I find there is a blank white page."

 

For a fresh copy of the code on the site? Not an upgrade?

 

The first page of the setup process shouldn't be attempting to access the database at all. It wouldn't know where the database is.

 

What I think is happening is that the Debugger class is creating a custom error_handler for PHP, then testing for a few things. If an error needs to be reported, the custom error handler also wants to post that to the database. But the database doesn't exist as yet.

 

In the file /classes/debug.class.php, at the end, please try this edit:

Was:
  private function _writeErrorLog($message) {
    Database::getInstance()->insert('CubeCart_system_error_log', array('message' => $message, 'time' => time()));
  }
}
 
Now:
  private function _writeErrorLog($message) {
    global $glob;
    if(isset($glob['dbdatabase']) || isset($GLOBALS['db'])) Database::getInstance()->insert('CubeCart_system_error_log', array('message' => $message, 'time' => time()));
  }
}

I haven't tested this as yet. But this should write to the database only if CubeCart knows about the database.

 

Thank you bsmither

 

The warnings and fatal error referring to the database have dissapeared. Now I'm just facing the first message on /setup/index.php:

 

Warning: register_globals are enabled. It is highly recommended that you disable this in your PHP configuration, as it is a large security hole, and may wreak havoc. in / *** / *** / *** /html/shop/classes/debug.class.php on line 156.

 

Thanks for further advises.

 

It is indeed a fresh installation. No upgrade.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...