Jump to content

Infinite loop when SSL is enabled in admin


Recommended Posts

Hi guys,
I recently installed a dedicated SSL on my site.
However when I enable it in CC admin, I get a "too many redirects" error in chrome and a similar message in other browsers.

If I disable SSL on CC admin and exchange "http" for "https" in the the address bar, the pages work fine.

CC is doing something, I just don't know what. Any help would be very much appreciated.

www.geekcore.co.uk is the site

Thanks again

Link to comment
Share on other sites

## File Security
<FilesMatch ".(htaccess)$">
 Order Allow,Deny
 Deny from all
#### Apache directory listing rules ####
DirectoryIndex index.php index.htm index.html
IndexIgnore *
#### Rewrite rules for SEO functionality ####
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteCond %{QUERY_STRING} (.*)$
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule cat_([0-9]+)(.[a-z]{3,4})?(.*)$ index.php?_a=category&cat_id=$1&%1 [NC]
  RewriteCond %{QUERY_STRING} (.*)$
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule prod_([0-9]+)(.[a-z]{3,4})?$ index.php?_a=product&product_id=$1&%1 [NC]
  RewriteCond %{QUERY_STRING} (.*)$
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule info_([0-9]+)(.[a-z]{3,4})?$ index.php?_a=document&doc_id=$1&%1 [NC]
  RewriteCond %{QUERY_STRING} (.*)$
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule tell_([0-9]+)(.[a-z]{3,4})?$ index.php?_a=product&product_id=$1&%1 [NC]
  RewriteCond %{QUERY_STRING} (.*)$
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule _saleItems(.[a-z]+)?(?.*)?$ index.php?_a=saleitems&%1 [NC,L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*).html?$ index.php?seo_path=$1 [L,QSA]
Link to comment
Share on other sites

I think it's something to do with the way when SSL is enabled, CC appends the URL with "&PHPSESSID=3e7cda9bf23fc15d982705a96c7afb7a"
If I remove this (when SSL is disabled in admin) the link works fine. Obviously if I do this with SSL enabled, it re-appends the link automatically.
How do I stop it from doing this?

Link to comment
Share on other sites

Did you read to the end of the post Bsmither suggested?


In case you didn't, try synchronizing your computer clock, even if it looks like it doesn't need it. Assuming you are on a Windows computer, click on the time in the right hand corner, then Change Date and Time Settings, the Internet Time tab, Change Settings, Update now.


Then reboot your browser and make sure it has cleared cache. Then clear cache from within CC Admin.

Link to comment
Share on other sites

"CC appends the URL with "&PHPSESSID={hash}"


I think this not a specific problem with CubeCart, but rather one where PHP itself will append this if the browser you are using is finicky with cookies. Either the browser has security settings too stringent, or you have a cookie-mangler add-on somewhere, or your firewall (ZoneAlarm?) is interfering, etc.


There are php.ini config file settings that can be set to anticipate finicky browsers.


But I could be wrong about this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...