Jump to content

SSL Settings Store URL won't store https


thirtyottsixx
 Share

Recommended Posts

My store is my entire site and I have an SSL enabled, shouldn't the Store URL under SSL settings be https://mydomain.com?  For some reason Cubecart 6 continually overwrites this with the non-secure http://mydomain.com version.  I have tried emptying the cache folder and deleting the cache through the admin panel and clearing it out.  It still defaults to http://mydomain.com regardless of what is entered in the field.

Edited by thirtyottsixx
Link to comment
Share on other sites

I do not know why this is coded to happen this way -- in Store Settings, SSL tab, the entry for 'Store URL' will always be 'adjusted' to hold a string that starts with http;//.

The question is, does any part of your store show as http:// when you have SSL enabled?

 

Link to comment
Share on other sites

No, everything seems to be operating under https.  I was actually able to get it to save once correctly last week by clearing the cache, emptying the field and saving but when I went back to the site today it was back to http.  While I had it set to "https" I was able to produce an accurate sitemap.  Otherwise it seems cubecart was generating a sitemap with all http URL's based on this setting.  I also noticed some weird crawling issues in Google.  Googlebot was reporting it was getting redirected and it was unable to index the site.  That issue looks to have resolved itself though.

Link to comment
Share on other sites

It is possible to get CC to show https for the store url. Leave it blank and save. It will stay that way unless you make any change to any store setting. BUT the http sitemap problem was fixed, unless a recent upgrade re-introduced it. I'm not at my computer and can't check right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...