Jump to content

Amzin (Bootstrap Responsive Skin)


Recommended Posts

Heya!

I am not sure what you mean by "modified version of cubecart"... I have edited some things in the script and such to make it do what it does, but is that what you mean by modified?

Can you look at my site and tell if it is modified and what issues I can expect when I do an update automatically from the extention section of the admin store?

https://www.store.mybikerleather.com

Thanks!

Rich

Link to comment
Share on other sites

8 minutes ago, radman420 said:

Heya!

I am not sure what you mean by "modified version of cubecart"... I have edited some things in the script and such to make it do what it does, but is that what you mean by modified?

Can you look at my site and tell if it is modified and what issues I can expect when I do an update automatically from the extention section of the admin store?

https://www.store.mybikerleather.com

Thanks!

Rich

Hey,

In relation to my answer to your previous question of "Can the core script be updated manually?" By "modified version of CubeCart" i mean if you have manually edited any of CubeCart's core script files. Using the upgrade option in the admin panel may cause the loss of any custom edits made to the core files.

 

In relation to Extensions such as Skins, if you modify them (Change colours by editing the css files, manually add additional html etc) then it's advisable that you do not use "install tokens" to install new versions of the skin as you will lose any previous edits to the skin. CubeCarts Install Tokens basically pulls the full new version of the extension (skin) from CubeCart servers and extracts it over the existing version (replacing the existing files with new files - restoring the skin back to its default version) but also merges so any extra files are not lost. Which is why i now do a manual update guide for any updates to my skins as most people modify the colour scheme at the least.

If that makes sense.

:)

  • Thanks 1
Link to comment
Share on other sites

That makes sense now. So where are the instructions for manual updates?

So you are saying that all the google codes in the headers and the background images and all...that will all have to be redone?

Which is more of a pain...doing auto and redoing all the work or doing a manual update?

Rich

Edited by radman420
Link to comment
Share on other sites

12 minutes ago, radman420 said:

That makes sense now. So where are the instructions for manual updates?

You can see the manual update guide for Amzin at http://nitefox.x10host.com/docs/ManualUpdates/amzinguide.html  - The latest update (V1.03) is mainly a compatibility update for CubeCart 6.4.0/6.4.1 

  • Thanks 1
Link to comment
Share on other sites

OK...so do those in order from 1.01 then 1.02 then 1.03?

After I do those, my cart will be fully updated? Can I skip any features, or are any absolutely necessary?

Why in version 1.03 does it say in a few of the steps, "requires version CC 6.41"? Am I not updating to that version by adding the lines of script?

 

Link to comment
Share on other sites

8 minutes ago, radman420 said:

OK...so do those in order from 1.01 then 1.02 then 1.03?

After I do those, my cart will be fully updated?

 

Hey,

No, you'd go from the one above the version you have installed  as any below it will already be done in the skin. So if you installed Amzin V1.02 then you'd only want V1.03 and above updates.

If you go to yoursite > skins > amzin > docs > changelog.txt  the top entry shows which version of amzin you had when you installed the skin.

 

Quote

Can I skip any features, or are any absolutely necessary?

I'm guessing you have Amzin V1.02 installed so the only one i would say is necessary would be on V1.03 - #23 Prevent Add To Cart Cache

Once your store is running CubeCart 6.4.1 then you'll need #16 to #21 (SEO EXT Support) to fix the login/register/search URLs 

 

Quote

Why in version 1.03 does it say in a few of the steps, "requires version CC 6.41"? Am I not updating to that version by adding the lines of script?

The updates in the guide only cover skin edits to support core features, some of which cover new features added in CubeCart V6.4.1. So to use those features you'd need to upgrade your store to  CubeCart V6.4.1 which is entirely separate from skin updates. Just doing skin updates won't update CubeCart's core.

 

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Hello again!

 

After updating my CC to 6.4.1, the popular products window on the left side disappeared...the code is still in the main file, but it isn't showing up on the pages. I have it turned on and number of sale items = 10.

Is this because I have not updated the skin completely or is it unrelated?

I appreciate your help...THANKS!

Rich

Link to comment
Share on other sites

Hi @radman420 

Sounds odd, neither the CC6.4.1 update or the skin update would affect the visibility of the popular products section as from my knowledge nothing was changed in relation to that. This behaviour is not occurring on any of my test setups so not sure what the cause would be. 

Have you tried going to site settings > layout and clicking save , then clear your sites cache ?

Also, if you right click on the area the box normally is then click "inspect" or "inspect element" can you any html code in the console panel that relates to the popular products?

Thanks,

NiteFox

  • Like 1
Link to comment
Share on other sites

I cleared cache...no fix.

Inspect element shoes nothing...like it isnt there.

www.mybikerleather.com

    <div class="panel panel-default site-navigation-container">
                        {include file='templates/box.navigation.php'}
                    </div>
                    
                    <div class="hidden-xs hidden-sm">
                        {include file='templates/box.featured.php'}
                        {if $PRODUCTS && $CONFIG['catalogue_sale_mode']>0 && $POPULAR}
                            <div class="row">
                                <div class="col-xs-12 col-sm-6 col-md-12">    
                                    {include file='templates/box.popular.php'}
                                </div>
                                <div class="col-xs-12 col-sm-6 col-md-12">
                                    {include file='templates/box.sale_items.php'}
                                </div>
                            </div>
                        {else}
                            {include file='templates/box.popular.php'}
                            {include file='templates/box.sale_items.php'}
                        {/if}

 

Something missing or...?

Link to comment
Share on other sites

Sorry...full div section:

<div class="hidden-xs hidden-sm">
                        {include file='templates/box.featured.php'}
                        {if $PRODUCTS && $CONFIG['catalogue_sale_mode']>0 && $POPULAR}
                            <div class="row">
                                <div class="col-xs-12 col-sm-6 col-md-12">    
                                    {include file='templates/box.popular.php'}
                                </div>
                                <div class="col-xs-12 col-sm-6 col-md-12">
                                    {include file='templates/box.sale_items.php'}
                                </div>
                            </div>
                        {else}
                            {include file='templates/box.popular.php'}
                            {include file='templates/box.sale_items.php'}
                        {/if}
                        
 
                        
                    </div>
                </div>

Link to comment
Share on other sites

@radman420 by data issue i mean that it would appear no data (in this case Products) is been supplied to the $POPULAR variable which is used to load the popular products section. Since it appears to happen in both the Foundation and Amzin skin that would suggest that it isn't caused by the skins.

All i can suggest is pop a message in Technical Help section as this is beyond a skin issue. Perhaps something went wrong during the CubeCart Update or a setting has changed. I'm running 6.4.1 with Amzin and Foundation and the popular box is loading fine so i'm not sure whats causing yours to not load since you updated.

  • Like 1
Link to comment
Share on other sites

In admin, Store Settings, Advanced tab, enable debugging and enter your IP address in the adjacent field (www.showmyip.com). Then, on the Layout tab, verify there is a value greater than '1' for Number of popular products to display. Also note the Source data for popular products.

Then request your homepage. At the bottom of the page will be a grey section with a lot of some diagnostic info.

If the source is by Product Views, then have the browser find ORDER BY popularity DESC. If by Sales, have the browser find ORDER BY `quantity` DESC.

If neither query is present, then we need to look elsewhere.

  • Like 1
Link to comment
Share on other sites

The debug section can be quite lengthy.

Your browser has the ability to Find things in the web page. Usually by the keyboard combo CTRL-f. In the small bar that opens (maybe at the bottom of the browser window) enter one of the terms I mentioned above. If not found, find for the other term.

Do NOT copy/paste the entire debug section into a forum post.

 

  • Like 1
Link to comment
Share on other sites

So, the browser did not find ORDER BY popularity DESC.

The next step I would like for you to do is edit the skin template box.popular.php and at the very end of the file, add {debug}. Save the edited file.

When you next ask for the Homepage, your browser will want to popup a window. Let it. (You may need to request the Homepage a second time if you need to give permission for the popup.)

The popup contains all the variables assigned to the template. Scroll down to near the bottom and find $POPULAR in the left pane.

If it is there, is there a value for it as shown in the right pane? It might be an array with 20 elements. (Do not post the array here. Just indicate if it is an array with 20 elements, or if the value is something else.)

 

Edited by bsmither
  • Like 1
Link to comment
Share on other sites

Please follow along with me. Let's look at /classes/gui.class.php, the private function _displayPopularProducts().

At the bottom of the function, near line 1275, a statement assigns the $content from fetching and rendering a template to $POPULAR_PRODUCTS. So we know the code gets executed down to that point.

Just above that statement is where all of the products from the query (in the $vars variable) is assigned to $POPULAR. But $POPULAR isn't in the diagnostics popup.

That's crazy. If 'POPULAR_PRODUCTS' got assigned something, then 'POPULAR' must have been assigned something, even if it is null or false.

Just above that is a hook. And above that, inside the foreach() loop, is a test that skips the product being examined if it does not have an associated category that has its status enabled.

What is still disconcerting to me is that the query isn't showing in the grey debug section. It really should be there, because, with the test near line 1240, if there are no $products from the query, none of what we just discussed gets executed.

Assuming the query is listed in the grey debug section, but wasn't correctly found, the only thing that could cause problems is: the test for enabled categories assigned to each product being looked at, or there being a hook that empties $vars.

In the grey debug section, near the bottom, are there any messages that indicate problems with any of the queries?

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...