Jump to content

Upgrade question


vidmarc
 Share

Recommended Posts

I'm trying to do the new upgrade but the Compatibility Check tells me I need the "IonCube PHP Loader".

 

I'm sure it was already installed last time, so what could have happened? My crappy hosting company (1&1) don't seem to want to help.

 

Any suggestions?

Link to comment
Share on other sites

Hi

If the hosting company is that bad then maybe move to one that isnt and guarantees to support CubeCart !

Alternatively you can install ionCube locally although this is something you shouldnt have to do and can lead to incompatibility issues on upgrades causing on-going work.

What version of CubeCart are you running currently and have you checked what encoder you are using currently (look in the includes/global.inc.php file) - my guess would be that you are on an older version of CC and using Zend which is no longer supported. The only two options you have are those above

Thanks

Ian

Link to comment
Share on other sites

Hi Ian,

 

I did try to install ionCube myself following 1&1's instructions but for some reason it doesn't seem to be working.

 

global.inc.php  = $glob['encoder'] = 'ioncube';

 

Here's what I see in admin:

 

 

 

The following errors were detected:
  • WARNING: Your store appears to be using source code from 5.2.14 but the database is still at 5.2.13.Please complete the upgrade by running the setup process.
Link to comment
Share on other sites

Hi

ionCube is working or your store wouldn't run. This problem is caused by a partial upgrade either because you have tried to do it manually and not completed the full process, or if doing it through the admin upgrade process, then it could easily have timed out. Many hosting companies have very low process time out settings which, when combined with overloaded servers, which cause processes to run even more slowly, can cause these problems.

If you still have the setup directory in your hosting account, then you can try running that manually or alternatively you can run each of the database statements in the setup/db/upgrade directory starting from the one after the version you are currently on

Thanks

Ian

Link to comment
Share on other sites

You say you still have the setup folder.

 

Call for this in your web browser:

http://www.mystore.com/setup/info.php

Look at the top section. It will show details about the version of PHP that is running. At the bottom of the top section, there will be phrases resembling:

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
  with ionCube Loader version x.y.z
  with Zend Encoder version x.y.z

Let us know what loaders/encoders are shown.

Link to comment
Share on other sites

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright © 1998-2014 Zend Technologies

 

and elsewhere:

 

 

Zend Extension 220100525

Zend Extension Build API220100525,NTS

 

 

 

Zend Signal Handling disabled

Zend Memory Manager enabled

Zend Multibyte Support provided by mbstring

 

No mention of ionCube Loader

Link to comment
Share on other sites

Recheck that you have followed the instructions to install ionCube.

 

If you are starting the installer by going here:

http://www.mystore.com/setup/index.php

you might need to put a copy of the php.ini file you created earlier into the /setup/ folder as well - as that is where the installer script (and info.php) starts running from.

Link to comment
Share on other sites

you might need to put a copy of the php.ini file you created earlier into the /setup/ folder as well - as that is where the installer script (and info.php) starts running from.

 

Thank you - this seems to have done the trick!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...