Jump to content

500 Internal Server Error when trying to access Dashboard


platedepot
 Share

Recommended Posts

When I'm trying to access the main Dashboard, I'm getting a 500 Internal Server Error (after trying for about a minute or so).  This error also occurs whenever I try to perform a store upgrade (although the upgrade does seem to go through).

 

Any suggestions?

 

Thanks

MARK

Link to comment
Share on other sites

I get this error:

 

[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: Entity: line 1: parser error : Space required after the Public Identifier in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: &lt;!DOCTYPE HTML PUBLIC &quot;-//IETF//DTD HTML 2.0//EN&quot;&gt; in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]:                                                  ^ in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: Entity: line 1: parser error : SystemLiteral &quot; or ' expected in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: &lt;!DOCTYPE HTML PUBLIC &quot;-//IETF//DTD HTML 2.0//EN&quot;&gt; in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]:                                                  ^ in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: Entity: line 1: parser error : SYSTEM or PUBLIC, the URI is missing in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]: &lt;!DOCTYPE HTML PUBLIC &quot;-//IETF//DTD HTML 2.0//EN&quot;&gt; in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  SimpleXMLElement::__construct() [<a href='http://docs.php.net/manual/en/simplexmlelement.--construct.php'>simplexmlelement.--construct.php</a>]:                                                  ^ in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 243
[20-Jan-2015 21:28:32] PHP Warning:  String could not be parsed as XML in /home/content/96/8861796/html/admin/sources/dashboard.index.inc.php on line 259

Link to comment
Share on other sites

Ok.

 

In the upgrading, it seems the following Store Setting was not updated. (Why? I don't know.) So, check and make sure it has for

Store Settings, Layout tab, "Default RSS URL for Admin Dashboard":

http://forums.cubecart.com/rss/forums/1-cubecart-news-announcements/
Link to comment
Share on other sites

 

Ok.

 

In the upgrading, it seems the following Store Setting was not updated. (Why? I don't know.) So, check and make sure it has for

Store Settings, Layout tab, "Default RSS URL for Admin Dashboard":

http://forums.cubecart.com/rss/forums/1-cubecart-news-announcements/

...My link for Default RSS URL for Admin Dashboard": is http://forums.cubecart.com/index.php?act=rssout&id=1

 

Is that an issue for my store if I wanted to do an upgrade ? Should I change it to the link you've suggested Brian?

 

Geoff

 

Please disregard, I've noticed in your post this should occur in the upgrade..

Link to comment
Share on other sites

Actually, I would hope the RSS URL to have been updated from an upgrade from way back to CC5.1.X, but I have not concluded that there is code that would have done this.

 

Please change the URL to what is given above.

 

The RSS URL configuration setting value does not affect the upgrade process.

Link to comment
Share on other sites

Actually, I would hope the RSS URL to have been updated from an upgrade from way back to CC5.1.X, but I have not concluded that there is code that would have done this.

The warning is harmless but can very quickly fill up your error_log file as it will be logged each and every time to go to the admin dashboard. It is caused by an old and no longer available rss url which is mostly seen when upgrading from a V4 store to V5 as we covered here https://www.havenswift-hosting.co.uk/manually-update-cubecart-default-rss-url-after-v4-to-v5-upgrade/

The RSS URL configuration setting value does not affect the upgrade process.

Doesnt affect the upgrade process and neither would it cause a 500 Internal Server Error.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...