Jump to content

CKEditor 4 Source Anomaly


bsmither
 Share

Recommended Posts

Only for CC6011:

In admin, Email Templates, Email Templates tab, click the Edit icon of Default Email.

On the page that shows, click the HTML Content tab. In the upper-left corner of the editor, enable "Source".

Please confirm if what you see is:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
</head>
<body bgcolor="#f7f7f7"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<style type="text/css">html, body, table {
	font-family: Arial;
	font-size: 14px;
}
</style>
</body>
</html>
<title>Default HTML Template</title>
<base href="{$DATA.storeURL}" />
<table border="0" cellpadding="0" cellspacing="0" width="100%">
	<tbody>
		<tr>
[the rest is not important]

This code is mal-formed in that content that is supposed to be in the <head> and <body> sections, aren't.

Link to comment
Share on other sites

I've not been able to get my logo to show on Outlook for some time, so since 6.0.11 I copied part of the Source Code from the demo store over to mine (didn't fix logo).

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
</head>
<body bgcolor="#f7f7f7"><meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
<style type="text/css">html, body, table {
	font-family: Arial;
	font-size: 14px;
}
</style>
</body>
</html>
<title>Default HTML Template</title>
<base href="{$DATA.storeURL}" />
<table border="0" cellpadding="0" cellspacing="0" width="100%">
	<tbody>
		<tr>
			<td align="center">
			<table bgcolor="#ffffff" border="0" cellpadding="15" cellspacing="0" width="580">
				<tbody>
					<tr>
						<td><a href="{$DATA.storeURL}"><img alt="{$DATA.storeName}" border="0" src="{$DATA.logoURL}" /></a></td>
					</tr>
					<tr>
						<td>{$EMAIL_CONTENT}</td>
					</tr>
					<tr>
						<td>
						<p>We&#39;re here to help,</p>

						<p>Rosemary</p>

						<p>The {$DATA.storeName}<br />
						<a href="{$DATA.storeURL}">{$DATA.storeURL}</a></p>
						</td>
					</tr>
				</tbody>
			</table>
			</td>
		</tr>
	</tbody>
</table>

<p>&nbsp;</p>

 

Link to comment
Share on other sites

Hello, I have this

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
</head>
<body bgcolor="#f7f7f7"><meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
<style type="text/css">html, body, table {
	font-family: Arial;
	font-size: 14px;
}
</style>
</body>
</html>
<title>Default HTML Template</title>
<base href="{$DATA.storeURL}" />
<base href="{$DATA.storeURL}" />
<table border="0" cellpadding="0" cellspacing="0" width="100%">
	<tbody>
		<tr>

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...