Jump to content

order without details


keat
 Share

Recommended Posts

This issue reared it's ugly head again today.

I never applied BSmithers fix (above) as he talks about the issue being caused by stock levels.

We don't use stock levels, every item is marked as infinitum, so I can rule out anything to do with reducing stock levels.

 

 

missing.jpg

Link to comment
Share on other sites

We must attempt to discover what these missing items are. If we cannot discern what was put in the shopping cart from info we find in the database, we must then look at web access logs to see the URLs that were used to look at site pages. So, grab a download of your site's web access logs if we need to look at those.

Link to comment
Share on other sites

Looking at the order history in the cart, I'm guessing that he's gone back and changed his order after pressing the continue button.

Despite my cart stating in huge bold letters "YOUR ORDER HAS NOW BEEN CONFIRMED, PRESSING THE BACK BUTTON AND CHANGING YOUR ORDER WILL ....BLAH BLAH BLAH"

Processing Yesterday, 11:32
Pending Yesterday, 11:31
Pending Yesterday, 11:30
Pending Yesterday, 11:20
Pending Yesterday, 11:11
Pending Yesterday, 11:11

I found his IP from the cart, then searching the raw access logs from the past few days, I only find 1 entry.

[13/Feb/2017:11:01:11 +0000] "GET / HTTP/1.1" 301 26 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) GSA/22.1.146053689 Mobile/14D27 Safari/600.1.4"


That's it, nothing more.

Link to comment
Share on other sites

  • 4 weeks later...

I got another one today, and a little more information from the user.

The user is using chrome, and added about 30 items to her cart, she clicked the continue button which took her to the paymant gateway page, at which point she says that the screen popped up a whole host of 'out of stock errors' in red.

She tells me that she never used the back button and that the cart was filled in a single session, in other words, it wasn't filled over a number of days.

I checked her IP against the order and confirmed with the customer via whatismyip.com, and I'm really well and truly confused.

In the raw access logs, I have a single entry for her IP.

The only entry for her IP is the following. (and this makes absolutely no sense)

78.xxx.xx.xxx - - [14/Mar/2017:07:23:41 +0000] "GET /images/uploads/F73-.jpg HTTP/1.1" 404 13 "http://vi.vipr.ebaydesc.com/ws/eBayISAPI.dll?ViewItemDescV4&item=371480875713&t=1460460393000&tid=310&category=20594&seller=bits4work&excSoj=1&excTrk=1&lsite=3&ittenable=false&domain=ebay.co.uk&descgauge=1" "Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0"

 

Firstly looking at the raw access log, it would indicate that the aformentioned IP, was coming through firefox via ebay (someone linking an image) and incurred an error when trying to open said image.

I assumed that maybe the customer visited ebay shortly afterwars, but she doesn't recall doing so, and besides, she tells me that she uses chrome, and this entry mentions firefox.

She did mention that she added battery terminals to her cart, and images/uploads/F73-.jpg was indeed a battery terminal when we had CC-V3.

 

Any other ideas ??

Link to comment
Share on other sites

If the "unknown" person and your customer both have dynamically assigned IP addresses, by the time you had your conversation with her, she may have acquired the IP address that the unknown person had some time ago.

If that may be the case, then note the time the order was placed (the Order Id adjusted for time zone differences, or some other time mark associated with the order).

Look in the raw access logs at around that time (adjusting for time zone differences), ignoring the IP address.

 

Link to comment
Share on other sites

The time stamps in apache logs are current, so It doesn't appear that there are any major time differences.

The order was placed in the cart at 07:21.

I spotted that there are two raw access logs, SSL and non SSL and found her entries in the SSL raw access logs.

It's quite obvious that she doesn't use chrome...:death:, but not obvious to me what went wrong.

Could you cast your eye over this data and see if it tells us anything.

 

http://www.cabletiefan.co.uk/webimages/data.txt

Link to comment
Share on other sites

I know this is a long shot, but could this be down to a part number that SQL doesn't like.

For instance, battery terminsls, which we can see in the data dump have part numbers like BT10+ (for a pos terminal) and BT10- (for a neg terminal).

Could SQL be interpretting the + or - as a non standard carachter and throwing an error.

Actually, I think I could rule that out, as she placed a sucessful order later in the day with a whole load of terminals.

Link to comment
Share on other sites

  • 4 weeks later...

I still have this, infcat, I got one last night, but I intend to update the site to 6.1.5 before progressing.

Before this, I intend to update PHP and apache, so I have a few evenings work in front of me (when I can get motivated)

Link to comment
Share on other sites

1 minute ago, keat said:

I still have this, infcat, I got one last night, but I intend to update the site to 6.1.5 before progressing.

Before this, I intend to update PHP and apache, so I have a few evenings work in front of me (when I can get motivated)

The current version should sort it. 6.1.6 is due after the bank holiday weekend which has numerous security hardening features. 

Link to comment
Share on other sites

I just looked at the link.

Whilst it looks great, the free session would last me about 8 hours.

And the lowest paid verion would probably last me about a month,...... tops.

I guess all well and good, if I could sign up for one month and experience the issue.

I'll probably wait for 6.1.6 and see if it continues after this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...