Jump to content

[Resolved] 1 Month after updating from V4 to V6.0.10 ALL LINKS BROKEN


Triscot
 Share

Recommended Posts

March 10, 2016 I updated from cubecart 4 to cubecart 6.0.10.  Everything seemed to be working except a shipping message error. I was testing at  http://africandesertcrafts.com/shop6 .  Bsmither solved the problem and I changed the the shop6 directory to shop to work with my wordpress menu.  I  checked the shop after changing directory name and all seemed in order.  I had not been back to this shop until today.  We just got an new, bigger, dedicated server from our hosting company and was in the process of moving all content to new server.  Out of about forty sites all went fairly well with the exception of Cubecart.  On the new server  http://africandesertcrafts.com/shop/* just showed a blank page, so I started a review.  I was shocked to find all of the links on the "old" server are broken, and some categories are missinghttp://africandesertcrafts.com/shop/*. Clicking on a featured products, best sellers, product types, and products by region all return 404 errors.  I went into the admin, maintenance and ran a "check" on all databases and all returned OK.  I reviewed the products and they are still there and able to be edited.

I have no idea what to do next???

*Note about servers:

*Both servers are using the same nameservers, and DNS points to both.  while in this moving stage I am using the "hosts" file on my local machine to switch between servers.  currently if one were to go to http://africandesertcrafts.com/shop/ they would be seeing the old server.

Link to comment
Share on other sites

A 404 response from the web server for a URL in the form of:

http://africandesertcrafts.com/shop/a-very-friendly-phrase-about-this-product.html

tells me that the web server is not "rewriting" the URLs. or is not getting a chance to do so. This URL:

http://africandesertcrafts.com/adventures-in-mali/dogon-country-pays-dogon-bandiagara-escarpment-mali/

seems to be getting processed, but by rules in the .htaccess file or by a process in the blog code, I cannot tell. (Probably blog code as these links may be what's called "perma-links"?) For example:

http://africandesertcrafts.com/shop/a-very-friendly-phrase-about-this-product.html
http://africandesertcrafts.com/shop
http://africandesertcrafts.com/adventures-in-mali/dogon-country-pays-dogon-bandiagara-escarpment-mali/

How is /shop/ getting differentiated from any other segment in the path? I see that /shop has no trailing slash, and if it does, what follows is different in that a CubeCart URL ends with .html.

Assuming for the moment that the .htaccess file has the rewrite rules, there must be a rule that first looks for ^/shop/(.*)\.html?$. If the URL is in this form, then rewrite it to look like /shop/index.php?seo_path=$1. (I do not know if the L in [L,QSA] is still appropriate.)

Then, if the above fails, it must be a blog URL.

(Probably, the RewriteBase directive, if any exist for /shop/, is not wanted.)

 

Link to comment
Share on other sites

New info. I found the original zip file shops6.zip made right after the V4 to V6... update. I extracted this file and using the path http://africandesertcrafts.com/shop6/ the shop works fine.  I then re-named the problem "shop" to shop6 and it worked.  So I will try resetting permalinks.

bsmither you nailed it again.  The problem turned out to be wordpress permalinks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...