Jump to content

Australia Post module error


Recommended Posts

For some reason where an item is added to the cart, is returns and error:

The following errors were detected:

  • Unfortunately there are no suitable shipping methods available for your order. This may be because the total weight of your order is too high or we cannot ship to your country.

I have changed anything (and the item selected is only light), apart from the fact that Cubecart was inaccessible and returned an error. I had our hosting provider look at it and he said that it was an incorrect PHP version which is strange because we hadn't changed it. I also have a problem with the Ebay Orders module which is showing a couple of blank pages. I have sent a message to Alec who developed the Ebay module and am waiting to hear back from him regarding the Ebay module.

My concern now is the Australia Post module showing that incorrect message.

Thanks Bruce.

Link to post
Share on other sites

Depending how the AusPost module communicates with their rate calculator, there should be a log entry in admin, Request Log.

Please let us know if there is anything in that log to be concerned about.

 

Link to post
Share on other sites

Hi,

The last Request Log shows:

Request Sent (fsock) - http://digitalapi.auspost.com.au/postage/parcel/domestic/service.json from_postcode=2852&to_postcode=2852&length=5&width=5&height=1&weight=1.31
Response received <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> <HTML><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1"> <TITLE>ERROR: The request could not be satisfied</TITLE> </HEAD><BODY> <H1>400 ERROR</H1> <H2>The request could not be satisfied.</H2> <HR noshade size="1px"> Bad request. We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner. <BR clear="all"> If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation. <BR clear="all"> <HR noshade size="1px"> <PRE> Generated by cloudfront (CloudFront) Request ID: PGcOKdv7uuEH5jYJwWgUHxZPEiNuF0pwygPYauOB8g7AZoA53aVYkA== </PRE> <ADDRESS> </ADDRESS> </BODY></HTML>
 
I just noticed that there should be a box where the customer can enter there post code to get a delivery cost. That isn't on the page.

 

Link to post
Share on other sites

In debug mode, there will be a lot more errors than normal, but these new log entries shouldn't all be red. (The legend above the log table has color-coded explanations.)

I would think AusPost could be out of commission at the moment, based on what the response is saying.

 

Link to post
Share on other sites

I just checked the Auspost API page here:  https://status.developers.auspost.com.au

and it indicates all is OK. I would have thought even if the API was the problem that the Refine Estimate calculator should still show but it doesn't.

I borrowed this image from one of the other posts, but this is the thing that is not showing either which makes me think that it is more than an API issue.

 

image.png

Link to post
Share on other sites

The error message shows "Bad request. We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner. "

Have you tried again now?

Link to post
Share on other sites

Hi Tony,

I just tried again now. Same issue.

I have checked the settings and all is the same as it was when it was working.

@bsmither I am wondering if for some reason there is a PHP extension not enabled that should be.

Link to post
Share on other sites

You would see that in the System Error Log.

The error posted above seems to come from CloudFront, not AusPost. As far as AudPost is concerned, they may not see anything amiss on their servers. On the other hand, I am sure they would be announcing something if there was a problem with CloudFront communicating with AusPost.

Edited by bsmither
Link to post
Share on other sites

In debug mode, it is showing an error. Not sure if this is causing the issue, @bsmither

1 Hack: 1614585575.50860 --- Duration: 943 µs [ERROR - NOT CACHED]
INSERT INTO `cc2h_CubeCart_system_error_log` (`message`,`url`,`backtrace`,`time`) VALUES ('[<strong>Notice</strong>] /home/kur49073/public_html/shop/classes/session.class.php:608 - Undefined index: samesite','https://www.kurraglenindustries.com.au/shop/index.php?','set_cookie() (session.class.php:721)\n_start() (session.class.php:165)\n__construct() (session.class.php:184)\ngetInstance() (controller.index.inc.php:37)\ninclude() (index.php:20)\n','1614585575');
Link to post
Share on other sites
Posted (edited)

Hmmmm. Bother. What now? Any other suggestions where to look?

Not sure if related but from the system error logs:

[<strong>Exception</strong>] /home/kur49073/public_html/shop/modules/plugins/ebay_orders/admin/eBaySession.php:0 - Call to undefined function curl_init()

Edited by kurraglen
Add information
Link to post
Share on other sites

That needs to get fixed. Have a conversation with your hosting provider that CURL is a required extension for your PHP.

The above mentions an eBay module - so whether this fixes the AusPost issue, I have hope. The AusPost uses CubeCart's Request functions, and they use CURL.

Request Sent (fsock)

This says that the Request functions had to use the alternate means of asking for information (fsock) instead of the usual means (curl).

Edited by bsmither
Link to post
Share on other sites

Thanks @bsmither, All appears to be working again with both the Aust Post and Ebay Orders module. I'm not sure why but, cURL had been disabled. They now have enabled it again.

Thanks and appreciate your help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...