Jump to content

Product Reviews APPROVAL


djcaseanova
 Share

Recommended Posts

I fiddled with the database to give a product a review, so that I could experiment with something. That review is not showing. It has also not yet been 'approved' in the admin Reviews list.

 

So, if your experience is such that unmoderated reviews are being displayed, that's a bad thing.

Link to comment
Share on other sites

  • 1 month later...

I have tried to post a test review and although I get sent to the moderator site to check the review, there are no reviews there to review? I also had a 'customer' leave a review, again I went to the admin page and there was no review to check, is this a bug or just another disappointment

Link to comment
Share on other sites

We would ask that you access the database directly and look in the CubeCart_reviews database table of the database being used by your CubeCart installation.

 

Earlier, I said that I manually added a review into CC_reviews and it all worked properly from the admin's point of view. (Why manually? At that time, inserting a record manually was simply far more quicker and easier -- for me.)

 

So, if you determine that there are no records in the CC_reviews table, then we can proceed to trace the code that should have inserted the data of a submitted review into the table.

 

If there are records, then we need to determine why your CubeCart fails to fetch or fails to show the reviews.

 

Also, would you please post the exact URL of the link given to you in the email advising you there is a review to be moderated. (You can disguise the domain name.)

 

According to the code, the link in the email (which, by the way, will not be sent if the INSERT command sent to the database fails) should look like:

admin.php?_g=products&node=reviews&edit=##

Link to comment
Share on other sites

Hi

I have found the database,i think, but I'm on the edge of my knowledge zone here. I have attached a screen shot. There does not appear to be anything there?

 

The path to my review was as follows..   domain.co.uk/admin.php?_g=products&node=reviews&edit=1

 

 

Link to comment
Share on other sites

The table you are showing appears to be part of a third-party mod -- probably from CC3. I say that because:

 

CC525:

    `id` INT UNSIGNED NOT NULL AUTO_INCREMENT,
    `approved` SMALLINT(1) UNSIGNED NOT NULL DEFAULT '0',
    `product_id` INT UNSIGNED NOT NULL DEFAULT '0',
    `customer_id` INT UNSIGNED NOT NULL DEFAULT '0',
    `rating` DECIMAL(2,1) UNSIGNED NOT NULL DEFAULT '0.0',
    `vote_up` INT NOT NULL DEFAULT '0',
    `vote_down` INT NOT NULL DEFAULT '0',
    `anon` TINYINT(1) UNSIGNED NOT NULL DEFAULT '0',
    `name` VARCHAR(255) NOT NULL,
    `email` VARCHAR(254) NOT NULL,
    `title` VARCHAR(255) NOT NULL,
    `review` TEXT NOT NULL,
    `ip_address` VARCHAR(45) NOT NULL COMMENT 'Supports IPv6 addresses',
    `time` INT UNSIGNED NOT NULL

 

CC447:

  `id` int(11) NOT NULL auto_increment,
  `approved` smallint(1) NOT NULL default '0',
  `productId` int(11) NOT NULL,
  `type` smallint(1) NOT NULL,
  `rating` smallint(1) NOT NULL,
  `name` varchar(255) NOT NULL,
  `email` varchar(254) NOT NULL,
  `title` varchar(255) NOT NULL,
  `review` text NOT NULL,
  `ip` varchar(45) NOT NULL,
  `time` int(10) NOT NULL

 

The structure in the image has almost all column names different than what is expected by CC5 (and as such, probably won't get inserted, but then, why did the database not report a failure to insert??? -- just thinking to myself).

 

To make sure you have the right database, look at the contents of the file /includes/global.inc.php. There should be the host, database, user, and pass of the database being used. According to the image, you are using phpMyAdmin to look at "rusticc3_ccrt1". Is this the name of the database in the file?

 

So, in phpMyAdmin, DROP (that is, delete) the CubeCart_reviews table.

 

Then in the SQL tab (hopefully there is an edit window here), enter the following and click Execute:

CREATE TABLE IF NOT EXISTS `CubeCart_reviews` (
    `id` INT UNSIGNED NOT NULL AUTO_INCREMENT,
    `approved` SMALLINT(1) UNSIGNED NOT NULL DEFAULT '0',
    `product_id` INT UNSIGNED NOT NULL DEFAULT '0',
    `customer_id` INT UNSIGNED NOT NULL DEFAULT '0',
    `rating` DECIMAL(2,1) UNSIGNED NOT NULL DEFAULT '0.0',
    `vote_up` INT NOT NULL DEFAULT '0',
    `vote_down` INT NOT NULL DEFAULT '0',
    `anon` TINYINT(1) UNSIGNED NOT NULL DEFAULT '0',
    `name` VARCHAR(255) NOT NULL,
    `email` VARCHAR(254) NOT NULL,
    `title` VARCHAR(255) NOT NULL,
    `review` TEXT NOT NULL,
    `ip_address` VARCHAR(45) NOT NULL COMMENT 'Supports IPv6 addresses',
    `time` INT UNSIGNED NOT NULL,
    PRIMARY KEY (`id`),
    KEY `product_id` (`product_id`),
    KEY `votes` (`vote_up`,`vote_down`),
    FULLTEXT KEY `fulltext` (`name`,`email`,`title`,`review`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
Link to comment
Share on other sites

I am sorry I am trying to keep up with you.When you say my actual password, what password is that, login to admin password, customer password, $globdb['password'] = 'xxxxxx'; 

 

and then I should delete the entire two lines mentioned above.

 

I paid CC for a license for a shop, I did not realise I would have to learn a different language to get it working, but I do appreciate you help.

Link to comment
Share on other sites

Well

I deleted the lines but it will not let me upload the edited file.

Command:    STOR global.inc.php
Response:    553 Can't open that file: Permission denied
Error:    Critical file transfer error
 


suggest you delete all these posts and we forget the whole conversation

Link to comment
Share on other sites

Let me try to be very clear:

 

By posting in these forums, anything you write can be read by anyone.

 

As such, we don't want to be posting personal or secret information in these forums. I hope that you would not want anyone to know your bank account numbers, social-security number (or what passes for a national id number in your country), credit card numbers, passwords to your Facebook account, etc.

 

In post #8 above, you have posted the password to your database. I am asking you to edit the post above. Do not make any changes to the CubeCart file global.inc.php.

 

Cubecart needs to know the user/pass to your database, and uses the information in the global.inc.php file to access the database.

 

The rest of the world does not need to know this information, and you really do not want the rest of the world to know this information.

Link to comment
Share on other sites

Hi

I have completed post #7 input and the reviews now work, there is an icon that appears in the review section , see attached, which take you to a sign up page for wordpress -

Sign in to Gravatar with WordPress.com Connect

Gravatar now allows you to use a WordPress.com account to sign in. If you have a WordPress.com account already then you can use that, or you can create a new one.

 

how do I stop that showing?

Link to comment
Share on other sites

In your skin's template file content.product.php, find a line that looks like this:

<p class="content"><a href="http://gravatar.com/emails/"><img src="http://www.gravatar.com/avatar/{$review.gravatar}?s=50" /></a>{$review.review}</p>

and change it to look like this:

<p class="content">{$review.review}</p>
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...