Jump to content

Problem with the cache


fabriceunko
 Share

Recommended Posts

I just noticed that I have a problem with the cache function. until now I was on the cache function enabled. I disabled the cache to see the changes I make on my skin test. and when I wanted the reactivated. the option remains systematically to disabled. not turned back on

Link to comment
Share on other sites

I just checked my 6.0.6, and I'm able to enable/disable cache at will. There were caching changes in 6.0.6 that were meant to make memcache possible, and maybe other similar files????? Are you using anything of that type?

yes I use memcached function, but I could still function on or off, I do it to see what I change the skin of foundation.
and yesterday I could disabled. but since not reactivated.
I have not touched the files (and other admin) just on my skin tests.

for the knob of the advance party in the parameter tab of the store before when it was turned off when I turned on the dashboard I had a message 'cache disabled please enable ....' to the disabled selector is locked on even if I chose I turned back on its still disabled and I go on the dashboard I have no message. I deduced that in fact it is posted but it is blocked off to on.

Link to comment
Share on other sites

  • 2 months later...

Check to see whether you have an entry in the includes/global.inc.php file which specifies which caching is used - upgrades to 6.0.7 adds the following line and causes a few problems

$glob['cache'] = 'file';

Problems caused then are

1) The admin store settings show caching as disabled and it isnt possible to change and save that as enabled (the config array actually stores it as enabled)

2) If you want to use memcached then in theory you should be able to change the entry as follows

$glob['cache'] = 'memcached';

but this causes an error - Fatal error: Class 'memcached' not found

so currently the only way to get memcached working is to delete the line completely from global.inc.php

In my opinion, the entry in the global.inc.php file should not be automatically added on an upgrade (although understand the reasons as the caching is coded currently which causes problems on some servers where memcached is installed but not available to be used).  I think a much better solution would be to change the enable / disable caching in the settings to a choice between disable and the list of caching options so you can choose which caching is used

Ian

 

Reported issue https://github.com/cubecart/v6/issues/822

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...