Jump to content

[Resolved] Registration and shopping cart problems


Frances Bloomer
 Share

Recommended Posts

Hi, everyone , I am trying to set up a cart at lacebobbins.com. I was setting up pages when the update notice came. So the cart was upgraded to the latest version a few weeks ago. 

I bought the Stripe module and went to test it, but the shopping cart will not respond.  It shows the totals of items added but does not come up at all, in any of the three browsers I checked. Mac, PC, server, old and new OS.  Cookies are on, so is JavaScript on the server.

I thought perhaps it wanted registration, so I tried that, and there is  nothing below the captcha block.  No continue button or way to get off the page at all.

If you click the  log in button at the top of the page, it will go to a log in page but reject your password, because the registration has not finished.

I would prefer that people do not have to register just to put in an order.

The Stripe module is checked as active but it does not show up on the Manage Hooks page, though I am not sure it is supposed to.

Quite frankly, I have been struggling with this for a while, if I cannot get this fixed, I have already been advised to switch carts.  I don't wish to do that, so any help would be very much appreciated.

Link to comment
Share on other sites

Hi @Frances Bloomer Welcome to the forums. Sorry you are having troubles.

Are you on version 1.0.5 of Stripe? If not, please upgrade to that as a start.

I'm assuming you are on CC v6.1.1? Are you using Foundation? Is your skin stock or has it been modified?

If you haven't already, please create the error log and provide samples of any messages you get when you try to use the Stripe module. Please be sure to write over your security admin naming with XXX's before displaying here.

I don't know anything at all about Stripe, but I'm assuming there is some kind of transaction log in Admin. If you have any entries there, provide those as well.

Hopefully someone with the skills to help you will be along shortly.

Link to comment
Share on other sites

Apologies, BSmither, I should have linked it since the cart is not yet active.     http://lacebobbins.com/cart/lace-bobbins-tools.html 

Dirty Butter, yes, the cart was upgraded to 6.1.1  The Stripe module was just bought and was 1.0.5.  Foundation skin Elegant by Bill Cooke, some modifications to the color of the backgrounds and Add to Basket, (basket was not working before this was done) and the header lettering.  I have not yet done anything with the front page and need to fix the logo, among other things!
 
I will work on getting the error log and post it when I have it. Learning as I go, here.  I can get into the settings for the Stripe module but that is all.  And it's possible I don't have it all set up right since this all started when I went to test it.
 
Also I had not tested the registration page previous to yesterday, so I do not know if it was working before or not.
 
Thank you both for your quick response.  I tried to send this the other day and did not do it right, apparently.
Link to comment
Share on other sites

Error log code installed on the server and this allowed the cart to show up there.  It did not respond on a pending order that was already there, but when I added new product, then it came up on my tablet. "The following errors were detected: Unfortunately there are no suitable shipping methods available for your order. This may be because the total weight of your order is too high or we cannot ship to your country. Please contact a member of our staff for any further inquiries."

Fine.  If you go on to the next step, the area for entering billing and shipping details is blank except for a comma under each, then the rest of the page seems to be there- but again, there is no further button to finish checkout.

I was able to empty the cart. I will check the shipping methods section.

Link to comment
Share on other sites

Sigh. I did not remember reading that I had to add a shipping module.  I'm on that and unless it gives me trouble as it has a few others, that should resolve the shopping cart problem.

Now, about the registration page and the checkout page not allowing me to exit....  

I'm new at this but I'll get there eventually.

Link to comment
Share on other sites

Progress! Shipping Module installed, error message gone in shopping cart.

But, I still can't finish a registration or get past the second page of checkout.  It's like the forms are not completely loading.  In fact, it did that in the Shipping Module- first time I clocked the add rates, I got only the first field, then a few minutes later I tried again and got the whole thing.

By the way, is it normal to have no way to leave the shopping cart page if you delete an item?  There is no link for home page or continue shopping or anything on mine.

Thanks for any suggestions.

Link to comment
Share on other sites

In looking at your CC store, I find that PHP is crashing just after the point where some HTML is rendered and output. The Elegant skin template main.php has this statement near line 153:

<script src="{$STORE_URL}/{$script|replace:'\\':'/'}" type="text/javascript"></script>

The statement is fine, but there is no HTML that follows it. There should be, at least, the "Powered by CubeCart" message.

That statement starts listing javascript (filenames, actually) from the $JS_SCRIPTS template variable. I think that Smarty is not liking the values that have been assigned to that variable (GUI class, line 170 - the $js array - there is also a statement just above it that globs for all the javascript files in the skin's /js/ or /scripts/ folder.

So, I think the skin has something wrong in its /js/ folder, or a plugin is mucking up the $js array variable.

The "no shipping available" may have appeared in the error_log, but there should be more in that file than what you have posted.

 

Link to comment
Share on other sites

Ok, bsmither, the Stripe module had status checked.  I unchecked, saved, and tried the pages- no change.  I rechecked the module.  On the other hand, the Manage Hooks page says there are no active/enabled plug-ins.  All I have are Stripe and AllInOne.  Here is the requested info.

For the folder /skins/elegant/js/

there is a folder called "vendor" and these 3 files

1.foundation.min.js

2.cubecart.js

3.cubecart.validate.js

readme.md

The error file is rather long..... it appears to have been doing this pretty much from the start, but I hadn't gotten around to testing those pages until about a week ago.  Sorry it's so long and repetetive.  Thanks for looking at this.

Link to comment
Share on other sites

Important: contact your hosting provider and have them to enable PHP's mbstring extension. (You may have this capability in your hosting account's control panel, PHP configuration.)

Error in the dashboard will be fixed in CubeCart's next release.

An error regarding cubecart.class.php on line 2087 is from not having any payment methods enabled.

Errors mentioning Shipping not setup is because there are no shipping methods enabled. Although, All-in-One-Shipping should take care of that, unless there are no shipping choices configured in the AIOS module.

Errors about number_format in acp.class.php on line 140 will be fixed in the next release.

Getting mbstring enabled should take care of the main issues you are having.

You can delete the contents of the error_log above from your post. And you can delete the error_log itself from your site's main folder.

Link to comment
Share on other sites

I thought it must be something I did or didn't do, mostly, and not the CubeCart software itself.  Happy to see this is so.  Working on it.  The skin's designer suggests trying to reload it, as he has not had this ever crop up before.

The shipping module and the Stripe module are checked in the status column.  Unless there is anywhere else they must be enabled, they should be good.

Thanks again, bsmither.

Link to comment
Share on other sites

5 hours ago, Frances Bloomer said:

I thought it must be something I did or didn't do, mostly, and not the CubeCart software itself.  Happy to see this is so.  Working on it.  The skin's designer suggests trying to reload it, as he has not had this ever crop up before.

This actually isn't anything to do with CubeCart either - mbstring is an extension of php that is needed by CubeCart and increasingly seems to be missing from some standard hosting environments.

CubeCart should not need reloading at all - simply ask your hosting company if they will enable mbstring which they should do but if they refuse for some reason, then you would need to move hosting companies

Ian

Link to comment
Share on other sites

I would disagree that the mbstring extension is available. Otherwise PHP would not complain about it.

Have your host tech support look again: in the PHP.INI file to enable the extension, and in whatever folder the actual extension code file would be sitting.

If you can get into your CubeCart admin, view the PHP Info page. Scroll to the table where "mbstring" would be (the tables are listed in alphabetical order).

If the table is there, then we have a very different problem.

If the table is not there, then the hosting tech support made a mistake.

Link to comment
Share on other sites

OK, I went back and we found that the mbstring table is in the php file in admin; the http translation was not enabled, so that has been put on.  Looks like we have that very different problem, bsmither.  The table appears as this now:

Multibyte Support enabled
Multibyte string engine libmbfl
HTTP input encoding translation enabled
libmbfl version 1.3.2

 

mbstring extension makes use of "streamable kanji code filter and converter", which is distributed under the GNU Lesser General Public License version 2.1.

 

Directive Local Value Master Value
mbstring.detect_order no value no value
mbstring.encoding_translation On On
mbstring.func_overload 0 0
mbstring.http_input auto auto
mbstring.http_output pass pass
mbstring.http_output_conv_mimetypes ^(text/|application/xhtml\+xml) ^(text/|application/xhtml\+xml)
mbstring.internal_encoding no value no value
mbstring.language neutral neutral
mbstring.strict_detection On On
mbstring.substitute_character no value no value

 

So far it does not seem to have made any difference, so is there anything else that needs to be changed?  There is still no "Powered by CubeCart" at the bottom of the pages, and the first time I opened one today it took minutes to load.

Thanks for your help-

Fran

Link to comment
Share on other sites

Please delete the error_log file and let it get re-written.

In admin, Maintenance, Rebuild tab, check Clear Cache and click Submit. This will dump any faulty-rendered skin templates.

Ask for the storefront HomePage. If mbstring is still a problem, it will be logged in the new error_log file.

Link to comment
Share on other sites

Admin Request Log, Error Log Admin and System files all show --None--.  But then, they did the other day too when there were errors. In Cpanel, I have one error about wordpress which I don't even have or use. Possibly someone trying to hack it.

I ran through all the shop pages, ran a purchase as far as it will go, deleted it, refreshed the error log on Cpanel, and nothing changed.

Fran

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...