Jump to content
Sign in to follow this  
exibar

HTML customer confirmation email possible?

Recommended Posts

Posted (edited)

hi there!

    Is it possible to send the customer a confirmation email that is in HTML?  kinda like the message that NEWEGG sends for the formatting?  With my company name and logo on the top, and details of their order?  I want my customers to receive something nice... not just a plain text email  that is drab and boring...

    Can I as admin also receive such a confirmation message?

 

 I just switched from OCART to CubeCart and I'm already liking the ease of use, and that everything just seems to make sense... Ocart really messes things up pretty badly and chooses the seemingly wrong way to do everything... the USPS shipping module wouldn't even work for me with a clean fresh scratch install!   but CUBECART works nice, I'm so happy I switched over.. and that's after running Ocart for 5 years of pain 😞

 

 thanks all!

 Mike B

Edited by exibar

Share this post


Link to post
Share on other sites

Welcome exibar! Glad to see you made it to the forums.

CubeCart sends multi-part emails: a plain text main body, and a rich text (HTML) standard attachment that rich text capable email programs will show by default if that attachment is present. The rich text component of the emails are as you describe: logos, names, etc.

CubeCart can be set to send the store admin(s) an email when the order is made (Pending) or when the order is ready for fulfillment (Processing). CubeCart sends the customer an email when the order has been paid for (Processing) and another email confirming that payment has been received. The admin's Processing email and the customer's Processing email look 99% identical, and all emails can be customized.

Share this post


Link to post
Share on other sites

is this all by default?  nice!

I'll dig to see where the settings are, but on the off chance I can't find it.  Could you point me in the right direction plz?  😉

 

 thanks!

 Mike B

Share this post


Link to post
Share on other sites

In CubeCart's administration backend, on the left navigation panel, click Email Templates.

The Email Contents tab is a list of all the main contents of CubeCart's emails - click the flag of the language you wish to edit.

The Email Templates tab is a list of the email's overall common content - click the Edit icon of Default Emails.

On the page that is now shown, click the HTML Content tab. (Do Not Edit Anything. Possible bug here.)

Hover the mouse over the blue squares to see a tooltip as to what protected content is here.

 

  • Like 1

Share this post


Link to post
Share on other sites

Using Foundation CC 6.2.4 and need to add the company logo to the customer receipt. Tried going through admin/email templates and even though I was successful in filling in the template (I think), the resulting emails still did not resolve the image. I also looked into altering the relevant PHP but didn't find it.

Share this post


Link to post
Share on other sites

The customer receipt that is an email?

CubeCart has several email "contents", and the content that is being used is inserted into an overall skeleton that includes the store logo. So, any email content managed in admin, Email Templates, will have the logo.

If you are referring to a printed sheet of paper, then in admin, Documents, Invoice Editor tab, there is a place for the {$STORE_LOGO}.

Share this post


Link to post
Share on other sites

It is in this case yes, delivery of download content (.zip)/link. I understand that the contents go into a skeleton however no logo of any kind is present and I see no PHP location to hard code it in. The template being used is New Order #{$DATA.cart order id} it seems automatically, (where to control that choice is my next question), right now i am trying to get the logo to appear. The image/s is in the 'images/logos' file.

I do see in the Admin settings a option for Logo/scope/other but no way to add that but to choose it instead of 'All Skins' ... or ... so I uploaded a new image/duplicate, set the Admin to Status 'yes' and Scope to 'Email Templates' so there are now two defined Logos/scope and gave that a go (sandbox purchase), no joy, next... I assumed this image load just rewrote/overwrote as there is no second file. so... Next, I changed the name and put that one up using the Admin/Settings/Logos feature, made mock purchase, still no joy. Is it possible that using the PP sandbox is effecting this?

Of course I cleared the cache all along. Seems so simple, but sometimes so frustrating.

Share this post


Link to post
Share on other sites

I am seeing the CKEditor really messing things up. However, that shouldn't affect Smarty (which populates these templates).

Share this post


Link to post
Share on other sites

Okay, so I fixed it, I think. You provided the answer some time back...

And it seems to work, so for now moving on to the next problem.

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...