Jump to content

Pages not showing unless I add .html extension


joelmalach
 Share

Recommended Posts

Hi. Something odd has happened to my Cubecart site today. Every page I click on shows 404 page not found.

After much checking, I have found that it will show the page if I add .html to the end of the url.

In my .htaccess file, it has 

    RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]

Which I think is correct

On my Settings, Store Settings, Search Engines page, it has the following settings

Add category to product URL path - No

Add subcategories to category URL path - Yes

SEO URL Extension - None

Product , Category & Document Meta Data - Disabled - Use global metadata only

I don't recall changing any of these settings.

Please, does anyone know what the solution is?

Link to comment
Share on other sites

Thanks both.

For clarity to anyone having the same problem, here's what is says in the Release Notes

If you see 404 errors after upgrade please either delete the .htaccess file so that it can automatically be regenerated or find;

RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]

and replace with

RewriteRule ^(.*)?$ index.php?seo_path=$1 [L,QSA]

Now working like a dream!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...