Jump to content

TDLWebs

Member
  • Posts

    66
  • Joined

  • Last visited

Everything posted by TDLWebs

  1. Hi, When viewing the System Error Log I am noticing lots of errors like the following: File: [seo.class.php] Line: [723] "INSERT INTO `CubeCart_seo_urls` (`redirect`,`type`,`item_id`,`path`,`custom`) VALUES ('0','prod','3795','london-transport-bus-timetables/london-transport-road-and-rail-timetable-1947-gravesend-and-district.html','0');" - Duplicate entry 'london-transport-bus-timetables/london-transport-road-and-rai...' for key 'PRIMARY' Any idea why this is happening? I have upgraded to version 6.4.2 cleared the cache etc.
  2. Fixed! I reinstalled the email templates and that did it. Don't know how I missed that but thanks very much for your help. THANK YOU bsmither!!!!!
  3. Ok, I did that and then attempted a password recovery. This is what I got (my asterisks): [11-Mar-2021 09:34:46 UTC] PHP Notice: Email content for account.password_recovery doesn't exist in default lamguage. in /home/sites/5b/6/**********/public_html/classes/mailer.class.php on line 132 [11-Mar-2021 09:34:46 UTC] PHP Notice: Email content for account.password_recovery doesn't exist in any lamguage. in /home/sites/5b/6/**********/public_html/classes/mailer.class.php on line 129 I guess that means the language file is corrupted?
  4. I've searched the forum and can't find a suitable answer to this, so: All other emails are being sent except for customer password recovery emails. I recently upgraded to 6.4.2 and thought that might fix it but regrettably not. For info: I have another site with an almost identical setup and that one works fine. Any suggestions? I'm really puzzled as to why this might be. Thanks! T
  5. I'm having the same issue. When I checked the email log it was empty, yet I know the site is sending order emails ok. Any ideas?
  6. That's very helpful, thanks. I am aware of the separate function to clear the image cache but still get time outs. I guess this is because of the huge number of images. Perhaps I should increase the max_execution_time ??? I have contacted my hosting provider regarding https://support.cubecart.com/hc/en-gb/articles/360003831737-How-do-I-enable-APC-Memcached-Redis-or-xCache- so they can advise the best setup. Is there an .htaccess in the image cache folder too? If so, I think if I was using SSH then I should enter something like $ rm -v !(".htaccess")
  7. This might be a silly question, but I thought I would ask before doing any damage Anyway... My client has a site which has thousands of products, all with associated images. Clearing the cache in admin can often take a long time and very often will time out before it has finished. My question is: Will it do any harm if I log into the server with SSH and manually delete everything in the 'cache' folder? Or is there anything in there that needs to be kept? It seems to me that this would be a lot quicker.
  8. Yes, that's it. My stupid error. I was concerned at losing the latest product details which had been added since and tried to be clever but failed miserably. Thanks again for your expert advice bsmither!
  9. Further investigation of the table shows: #1062 - Duplicate entry '17942' for key 'PRIMARY'
  10. After my issues with missing images I had to restore the CubeCart_filemanager table in the database by merging two backup files. However, this has created duplicate entries with the result that there is no primary key etc. Images can no longer be allocated to products in admin. I have located the duplicates using the query: SELECT filename, COUNT(filename) FROM CubeCart_filemanager GROUP BY filename HAVING COUNT(filename) > 1; But some images are used twice; once by a product and once by a category - as seen when I search for a particular image filename which is duplicated (see db-image1.jpg below) They also have identical md5hash entries. The phpmyadmin screenshot taken from a healthy CubeCart_filemanager table should have the structure seen in db-image2.jpg below: Any idea how can I remove the unnecessary duplicates and restore the integrity of the CubeCart_filemanager table????
  11. Fantastic! That appears to have fixed it Thank you VERY MUCH!!!!!
  12. Ok, done that. The only file_id number shown in the result was 15725 . When I tried to find 15725 in Cubecart_filemanager there was nothing:
  13. Ok, thanks. Here is what I found for one of the listings: And this for a newly added product with the image showing up ok: They look the same to me, but maybe I'm looking at the wrong thing????
  14. I have cleared the cache and reloaded admin so believe that the latest version of Javascript is being used. The absence of the scrollbar is due to the Mac OS - it appears when I start to scroll. CubeCart_filemanager in the database shows 14256 rows I'm not sure that I'm looking at the right thing in Chrome developer tools: The code is from the view product template and the skin is Galaxy X
  15. cubecart_image_index = 12387 rows Yes, most of the records have a non-zero value although there are some zeros
  16. When I inspect the source code it says (unknown) in the img src ????
  17. No, it's clear now. I read the thread on Github but no clues there either. I'm totally flummoxed.
  18. Yes, they all appear to be there on the server. But for some reason, don't seem to be associated with the categories or products any more.
  19. No, unfortunately not. Nothing I've tried works. I really need an expert to take a look behind the scenes to confirm whether it can be recovered or not. Any offers?
  20. Hi bsmither, Thanks for your response. I fixed the stock settings by entering an integer as advised. I can confirm that 6.2.8 is now listed but there was a warning in admin for a while advising that the files had updated but the database hadn't. After running a manual upgrade this went away.
  21. I recently upgraded a store from v6.2.2 to 6.2.8 and now there are thousands of images not showing up, both in categories and products. The upgrade failed from the admin option so I had to manually upload the 6.2.8 files and perform a manual upgrade. The System Error Log is showing; File: [dashboard.index.inc.php] Line: [360] "SELECT I.name, I.product_code, I.stock_level AS I_stock_level, I.stock_warning AS I_stock_warning, I.product_id, M.stock_level AS M_stock_level, M.use_stock as M_use_stock, M.cached_name FROM `CubeCart_inventory` AS `I` LEFT JOIN `CubeCart_option_matrix` AS `M` on `I`.`product_id` = `M`.`product_id` WHERE use_stock_level = 1 AND ((M.status = 1 AND M.use_stock = 1 AND M.stock_level <= ) OR (I.stock_level <= )) ;" - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ') OR (I.stock_level <= ))' at line 1 and on Database Maintenance there is; CubeCart_order_summary.custom_oid has a key type KEY but expecting UNIQUE KEY. The site literally does feature thousands of products and the cache is huge, so I don't know if that has anything to do with it. Can anybody offer help? I will be happy to pay for a fix. T
×
×
  • Create New...