Jump to content

[Resolved] Admin Login error 403 forbidden


Recommended Posts

Hi
I've had this problem from previous CC versions after my host updated the server some time ago and CubeCart updates haven't fixed the issue.

When I use the Store Control Panel Login with Username: and Password: I get taken to a page saying "403 forbidden - Access to this resource on the server is denied!"
It's like the login - password checking page or script is missing.
I've tried it in Firefox, Chrome and Explorer.

The only way I can log in is using the "Forgotten your password?" which works.
During CC updates, all files say they are writeable.

I have tried forcefully changing the admin password by following the video: 

but it did not work.

 

I have two stores in seperate directories on the server - both are doing it, not sure if that is part of the issue.
Hosting says PHP version is 5.522 on a linux system.
My CPanel error Log says the following - which probably doesn't help:
2015-03-27 12:54:04.494 [iNFO] [203.206.58.207:63107-0#APVH_ontas.net] File not found [/home/abcedgec/public_html/403.shtml] 

 

Thanks for your time.

Link to post
Share on other sites

Does a friend located somewhere else on the planet get the same response?

 

The reason I ask is because of a setup I have created on a local server is to deny all access except for a specific range of IP addresses. Any access not in this range gets a 403 response.

 

So, something on your server, or a configuration of the web server on that system, or a directive in the .htaccess file, is actively denying access to everyone -- or maybe just you.

 

I suspect it may not be a folder/file permissions problem (I don't run Linux, so I can't make experiments to check). On the other hand, you say "Forgot Password" function works and you can get in.

 

Hopefully, someone more knowledgeable about server operations will be by soon.

Link to post
Share on other sites

Thanks for the quick response.

We get the same result when we try to log in from our shop PC or home PC and so does the person I set up the other store for.
I just checked the IP Address Deny Manager in CPanel and no IP addresses or ranges are blocked.

Your comment about IP addresses got me thinking, I remembered seeing ip_address when I changed the admin password in phpMyAdmin.
I just tried deleting the ip_address in CubeCart_admin_users but that still didn't work.


I also noticed while looking for it again, there is also a eui_CubeCart_admin_users table.
This one contains the two admin accounts I have set up (neither can log in with password but can use forgot password) but the CubeCart_admin_users contains only the first admin account I set up.
 


Thanks for the quick response.

We get the same result when we try to log in from our shop PC or home PC and so does the person I set up the other store for.
I just checked the IP Address Deny Manager in CPanel and no IP addresses or ranges are blocked.

Your comment about IP addresses got me thinking, I remembered seeing ip_address when I changed the admin password in phpMyAdmin.
I just tried deleting the ip_address in CubeCart_admin_users but that still didn't work.


I also noticed while looking for it again, there is also a eui_CubeCart_admin_users table.
This one contains the two admin accounts I have set up (neither can log in with password but can use forgot password) but the CubeCart_admin_users contains only the first admin account I set up.

Link to post
Share on other sites

From my experience this issue is almost always caused by server security rules blocking the PHP code executing. Please can you ask your host what rule is being broken preventing it working and if they can relax it for your account. I doubt anything needs changing in your CubeCart files.

Link to post
Share on other sites

Thanks for the quick response.

We get the same result when we try to log in from our shop PC or home PC and so does the person I set up the other store for.
I just checked the IP Address Deny Manager in CPanel and no IP addresses or ranges are blocked.

Your comment about IP addresses got me thinking, I remembered seeing ip_address when I changed the admin password in phpMyAdmin.
I just tried deleting the ip_address in CubeCart_admin_users but that still didn't work.


I also noticed while looking for it again, there is also a eui_CubeCart_admin_users table.
This one contains the two admin accounts I have set up (neither can log in with password but can use forgot password) but the CubeCart_admin_users contains only the first admin account I set up.

 

 

Thanks Al, I will contact the site host. This does seem likely since it started happening after one of their server upgrades.
Cheers.


Thanks for the quick response.

We get the same result when we try to log in from our shop PC or home PC and so does the person I set up the other store for.
I just checked the IP Address Deny Manager in CPanel and no IP addresses or ranges are blocked.

Your comment about IP addresses got me thinking, I remembered seeing ip_address when I changed the admin password in phpMyAdmin.
I just tried deleting the ip_address in CubeCart_admin_users but that still didn't work.


I also noticed while looking for it again, there is also a eui_CubeCart_admin_users table.
This one contains the two admin accounts I have set up (neither can log in with password but can use forgot password) but the CubeCart_admin_users contains only the first admin account I set up.

 

 

Thanks Al, I will contact the site host. This does seem likely since it started happening after one of their server upgrades.
Cheers.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...