Jump to content
Sign in to follow this  
CubeCart Bot

Bank Transfer

Recommended Posts

There's a spelling mistake in the description

Also when installing, updating the bank details, save it and is says Cross Site Forgery. Tried logging in and out and every time it fails to work. Other extensions are fine.

Share this post


Link to post
Share on other sites

Tried again today, it's not possible to update any of the bank information in this app without error.

Edited by Retrodisco

Share this post


Link to post
Share on other sites
On 2/26/2019 at 2:34 PM, Retrodisco said:

There's a spelling mistake in the description

There are two spelling mistakes and the text is hard coded rather than being in a language string - reported here : https://github.com/cubecart/v6/issues/2250

On 2/28/2019 at 11:58 AM, Retrodisco said:

Tried again today, it's not possible to update any of the bank information in this app without error.

Just installed this and tested it for a client and dont see any cross site errors when updating the details

Share this post


Link to post
Share on other sites

In the module's file /skin/admin/index.tpl, near the end, add the new line as shown:

  <div class="form_control"><input type="submit" name="save" value="{$LANG.common.save}" /></div>
{* This line added! *}  <input type="hidden" name="token" value="{$SESSION_TOKEN}" />
</form>

 

Share this post


Link to post
Share on other sites

I'm using the latest version, the cross site forgery issue was with the latest cubecart. I'm not alone with this issue.

Share this post


Link to post
Share on other sites

You think you are using the latest version but you are not. 

If in your folder structure you see and admin folder and a renamed admin folder it is likely that the admin folder (with latest code) is not in use!

./admin
./admin_abc123

The name will vary but you need to rename the admin folder admin_abc123 and delete the admin_abc123 folder. 

Share this post


Link to post
Share on other sites

Agreed - failed upgrades have been very common in the past when done via the built in upgrade option  and often result in a mix of files from different versions - this will cause this type of problem.  It has been covered in quite a few threads on here before and a manual upgrade would definitely solve it.

Ian

  • Like 1

Share this post


Link to post
Share on other sites

I've renamed the admin folder, it now contains todays update files.

This extension still fails on cross site forgery error

Share this post


Link to post
Share on other sites
1 minute ago, Retrodisco said:

I've renamed the admin folder, it now contains todays update files.

This extension still fails on cross site forgery error

The store still isn't at latest code base then.

Share this post


Link to post
Share on other sites

It's worse.

I've just updated, then uploaded admin folder manually, and checked it is the right folder name, now everything is cross site forgery, I can't login at all, from laptop or phone. The whole site is locked out.

Share this post


Link to post
Share on other sites

The admin.php file (or however it has been renamed) needs to be from the same version as the files in the admin directory

Share this post


Link to post
Share on other sites

Exactly. Your store is still using a mix and match of old and new files.

Share this post


Link to post
Share on other sites

Everything working now. Aside from this extension, which seems to have a lot of bother retaining the information entered in the boxes. Just disappears even after save.

Share this post


Link to post
Share on other sites

Hi. I'm having a bit of a problem with this Extension.

1. After a customer checks out, it displays a screen with the following

------------------------------------------------------------------------------------

Amount Due

A total of €26.95 is due for order number 190423-105827-6658

Your order will be completed once payment has been received.

-----------------------------------------------------------------------------

The bank details for the customer to pay into do not show, although I have entered them in the Manage Extensions area in the admin area

How does the client know who to pay?

I would expect the bank details to show on screen or an email sent to the client with the bank details 

 

2. I do not receive an email notification of the order, even though I have set "Order status for admin email notifications" to "Pending" 

Emails are working on the site when I do a test

Please can you advise what I'm doing wrong

Thanks

Joel

Hi - problem partially solved

Although I had entered the bank details, etc, I hadn't entered the titles - e.g. Account Name, Account Number, etc.

Once I entered the titles, it now shows on screen

However, I'm still not receiving an email notification, so any help with that would be appreciated

Share this post


Link to post
Share on other sites

According to the Bank Transfer module code, it does not ask CubeCart to send any emails - compared to POF that sends an email to the customer.

But CubeCart not sending an Order Received email when the order goes to Pending is strange.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...