Jump to content

firefox vs edge


Recommended Posts

Its that time of year where I work on a duplicate web site, making price chnages ready for 2021.

Last year I complained of a delay between clicking the product and the price tab opening. (BSmither gave me a fix to open the price tab first)

Then when it did open, I couldnt modify the price until the page had fully loaded.

Enter new price, the pressing enter, took a second or so for the page to refresh.

In total, changing one price took maybe 5 or 6 seconds.

Not a long time being fair, however, when you've 1000's to do, and it takes you three weeks, you'll understand the frustration of waiting.

 

Today, suffering the same fate, I decided to see if the browser was the issue.

MS Edge is twice the speed.

Link to post
Share on other sites

If your browser has a Developer's set of features, please view its Javascript Console diagnostics page. There may be a clue posted there mentioning any problems that the javascript may be happening. (Switching among tabs on a page is javascript-powered.)

 

Link to post
Share on other sites
21 minutes ago, bsmither said:

If your browser has a Developer's set of features, please view its Javascript Console diagnostics page. There may be a clue posted there mentioning any problems that the javascript may be happening. (Switching among tabs on a page is javascript-powered.)

 

I've just noticed the tabbing issue.

Seems when the cache is disabled it causes a JS issue 

"Uncaught TypeError: cannot read property 'split' of undefined "

Related line admin.js 671

var ccp = cc.split("#"); 

Link to post
Share on other sites

There is a code change that I do not agree with: If the admin turns off caching, the "Clear Cache" button is not shown.

In my opinion, there may be instances where clearing the cache would be necessary, even if it was disabled.

(If I recall, disabling the cache does not clear it, switching to a new cache method does not clear either the losing or acquiring cache method, nor re-enabling the cache automatically clears it - common-sense housekeeping. So, I feel keeping the button visible is warranted.)

When the button is suppressed from being shown, the node identifier, <li id="clear_cache_master", is not present in the HTML. Thus, the javascript is not able to locate this node and javascript basically quits.

In the admin template common.breadcrumb.php, near line 10:

Find:

{if $CONFIG.cache}<li id="clear_cache_master"{if $CLEAR_CACHE} class="clear"{/if}><a href="{$SKIN_VARS.clear_cache_link}">{$LANG.maintain.cache_clear}</a></li>{/if}

Change to:

<li id="clear_cache_master"{if $CLEAR_CACHE} class="clear"{/if}><a href="{$SKIN_VARS.clear_cache_link}">{$LANG.maintain.cache_clear}</a></li>

I've not tested this yet, as the javascript code that is looking for this node is new to CC641.

Edited by bsmither
Link to post
Share on other sites
On 11/11/2020 at 4:56 PM, NiteFox said:

I've just noticed the tabbing issue.

Seems when the cache is disabled it causes a JS issue 

"Uncaught TypeError: cannot read property 'split' of undefined "

Related line admin.js 671

var ccp = cc.split("#"); 

Yes its this for sure. I have cache off and the tabs dont work.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...