Jump to content

harrisorganic

Member
  • Posts

    372
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by harrisorganic

  1. Hi, I have looked around the forum and want to change the $store url to my non store home page ie https:www.example.com.au/ instead of https:www.example.com.au/ store. I want to customer to be able to click on the LH icon and go to https:www.example.com.au/ leaving the house for the store home. I though it may have been box.navigation.php, but no. Also is it best to make a parameter like $STORE_HOME, if so how to do it.?
  2. Possibility that my htaccess file was providing some miss info/redirects. two days ago I simplified it, ie removing all the bells and whistles. I really need someone who knows htaccess syntax, it is not my field. About to put a contract on upwork for some one to look at it. Yep, wild guessing.!
  3. After changing $request->skiplog(false); // was truethe Request Log showsDate Yesterday, 16:25Request Sent - https://www.cubecart.com/version-check/2.3.22version=6.0.8Response received<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>400 Bad Request</title> </head><body> <h1>Bad Request</h1> <p>Your browser sent a request that this server could not understand.<br /> Reason: You're speaking plain HTTP to an SSL-enabled server port.<br /> Instead use the HTTPS scheme to access this URL, please.<br /> </p> <p>Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.</p> </body></html>
  4. Here is the error log from yesterday and screen shots of the upgrade page and Dashboard. As you can see there is no upgrade advice. [15-Jan-2016 15:24:25 Australia/Perth] PHP Warning: array_merge() [<a href='http://docs.php.net/manual/en/function.array-merge.php'>function.array-merge.php</a>]: Argument #2 is not an array in /home1/maketext/public_html/harrisorganicwine/shop/admin/sources/orders.index.inc.php on line 238 [15-Jan-2016 09:00:47 UTC] PHP Warning: Stored session data did not match DB record. Session aborted as possible session hijack. Old IP Address: '58.84.162.133' New IP Address: '58.84.162.133' Old User Agent: 'Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36' New User Agent: 'Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36' in /home1/maketext/public_html/harrisorganicwine/shop/classes/session.class.php on line 651
  5. Even after rebooting my PC, and logging in to the admin page there is no upgrade notice. What would happen if I clicked on Force upgrade?
  6. My admin page is not showing an upgrade is required from 6.08 to 6.09. This is not normal, usually when I log in I get a banner in red. Anyone else (not) seeing this?
  7. If you are stuck with adding a handling fee can you incorporate it in the postage fee? (All in one shipping) AIOS should be OK for that.
  8. Here is a section of yesterday's access log with baidu spider listed and perpage=96 96.31.66.245 - - [11/Jan/2016:05:31:04 -0700] "GET / HTTP/1.1" 200 14432 "-" "Pingdom.com_bot_version_1.4_(http://www.pingdom.com)" 180.76.15.134 - - [11/Jan/2016:05:31:46 -0700] "GET /shop/dry-reds.html?perpage=96 HTTP/1.1" 200 44467 "-" "Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)" 46.20.45.18 - - [11/Jan/2016:05:32:04 -0700] "GET / HTTP/1.1" 200 14432 "-" "Pingdom.com_bot_version_1.4_(http://www.pingdom.com)" CC error log shows some repeated lines of: [11-Jan-2016 13:22:17 Australia/Perth] PHP Warning: Invalid argument supplied for foreach() in /home1/maketext/public_html/harrisorganicwine/shop/modules/gateway/Card_Capture/gateway.class.php on line 127 [11-Jan-2016 13:30:55 Australia/Perth] PHP Warning: array_merge() [<a href='http://docs.php.net/manual/en/function.array-merge.php'>function.array-merge.php</a>]: Argument #2 is not an array in /home1/maketext/public_html/harrisorganicwine/shop/admin/sources/orders.index.inc.php on line 238 to add something else to the story.
  9. Please see the attached snippet regarding the statistics users online page The m. and the swanvalley.mobi are strange bed fellows. I don’t know if this is still an htaccess issue or a caching issue. Any thoughts? The site works OK , as I received two orders in the past 24hrs.
  10. Following on from this topic I asked CC some time ago about logging in with Facebook or other social media logins so that it is easier for customers to login. I hope it is available as a plugin soon.
  11. Seems to me that the htaccess code rewrite is not working. Testing the below with input url of http://www.harrisorganicwine.com.au RewriteEngine on RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] The new url is https://www.harrisorganicwine.com.au/ Test are stopped, a redirect will be made with status code 301 other rules are required. Line 75 in htaccess is turned off and if used gives http://www.harrisorganicwine.com.au/https\:\/\/www\.harrisorganicwine\.com\.au\/ which of course is not correct. .htaccess
  12. Found it: in the std log access file. 40.77.167.14 - - [05/Jan/2016:22:39:14 -0700] "GET / HTTP/1.1" 301 617 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)" 70.89.163.49 - - [05/Jan/2016:22:39:25 -0700] "GET /shop/dry-whites.html HTTP/1.1" 200 14304 "https://www.m. ......."Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0" 70.89.163.49 - - [05/Jan/2016:22:39:26 -0700] "GET /shop/images/cache/Wine/Chilli-White-Wine.190.jpg HTTP/1.1" 200 6708 "https://www.harrisorganicwine.com.au/shop/organic-white.html" "Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0" 70.89.163.49 - - [05/Jan/2016:22:39:26 -0700] "GET /shop/images/cache/Wine/verd.190.jpg HTTP/1.1" 200 12074 "https://www.harrisorganicwine.com.au/shop/organic-white.html" "Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0" 70.89.163.49 - - [05/Jan/2016:22:39:26 -0700] "GET /shop/images/cache/Wine/chardonnay.190.jpg HTTP/1.1" 200 11450 "https://www.harrisorganicwine.com.au/shop/organic-white.html" "Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0" 70.89.163.49 - - [05/Jan/2016:22:39:26 -0700] "GET /shop/images/cache/Wine/organic-sherry_thumb.190.jpg HTTP/1.1" 200 7733 "https://www.harrisorganicwine.com.au/shop/organic-white.html" "Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0" When I look at my shop home page now, I get www.m. in the category bar and if I refresh the page it is still there. I used to have a website called m. harrisorganicwine.com.au that redirected to harrisorganicwine.com.au. I turned that off last month. Today I found a subdomain of that name and remove it. m. harrisorganicwine.com.au continues in the cat. bar.
  13. Hi Brian, I found the access logs, there was two, one for the month and one for yesterday. Neither had www.m..... All we can do is wait and see if it happens again, then grab the access logs. Having said that, Al has fixed the plugin update issue and said "This is the first time I've seen the token installer fail. I fixed it by removing the "null data" sent with the request. I expect a slightly different server config or cURL version is the reason. " Whether there is some relationship, between the issues, I have no idea, but worth mentioning. best regards Duncan
  14. Sort of but, I believe, it was not related to the 403 error regarding the cubecart security plugin where I had inserted the static IP address. Once the security plugin was updated the url issue was still there.
  15. Hi Brian, This issue raised its ugly head a few weeks ago. I found that the category bar gives an unusual url when I am mousing over an item. On any page not just the front page gives the incorrect url. eg. https://www.harrisorganicwine.com.au/shop/ Hover over the word category sparkling gives https://www.harrisorganicwine.com.au/shop/sparkling.html where there should be no "m." I have not been able to find what turns it on and off, but it does come and go without any input from myself. As an example it appeared this morning and then I refreshed the page and it was gone, other times refreshing does nothing. I have tested this on another Pc too with the same error. However on other sections of the page, ie the latest product area or best sellers there is no issue. So there is some thing effecting the category bar . Todays error log is attached, noting there is an issue with the plugin area which I have asked Al at Cubecart to look into. Any thoughts where to check this out; possibly waiting until the plugin situation is cleared up, but I dont know which one may or may not be effecting these issues. error_log
  16. When I tried to update several plugins today I get an error when I insert the new token to update a plugin. A red bar come up and it reads, " Its not been possible to read the contents of the file." I found that if I manually down load/upload the files, the token works. I did a search of cubecart and did not find any prior art on this issue. Has any one else seen this? Any ideas? upgrades.docx
  17. Great that this is on the to-do list Al. Meanwhile I have been checking what can be updated. I am getting an error when I insert the new token to update a plugin. A red bar come up and it reads, " Its not been possible to read the contents of the file." I found that if I manually down load the files, the token works. I did a search of cubecart and did not find and prior art to this issue. Any ideas? upgrades.docx
  18. Thanks Brian, Your thoroughness is to be admired. I am now able to access CC admin again All I did was change the IP address in Cubecart_ccss_ip_addresses. I also learnt that the websites dedicated IP is not the same as my user IP. After reading through DB's comments re this plugin, I am turning it off until a revision is made. Why should you and I spend so much time learning about some bugs in a system. A plugin.that could have been documented better for all to use, and one that does not tick boxes when you click save. Thanks again. PS there is a revision available 1.0.6 - Fixed error with creation of CubeCart_ccss_ip_addresses with database prefix I was using 1.0.1
  19. Hi DB, Happy holidays, Just like you, I took the holiday time to improve my security with this plugin and found after one very frustrating week of no admin page, I made the same observations you have made. see above. I seriously suggest that Al and his CC team provide some better help information and thoroughness to this plugin so you, me, Ian and Brian could spend our valuable time not pulling our hair out. There are many questions to be answered. The designer of this plugin should provide these before I take my chances again. PS there is a revision available 1.0.6 - Fixed error with creation of CubeCart_ccss_ip_addresses with database prefix
  20. The question on my mind is how to get to the security plugin without the use of admin page? I have a Dedicated IP and that number I entered in the security plugin.
  21. I am wondering if this is my issue as I was playing with the security plugin at the time? https://forums.cubecart.com/topic/50237-resolved-403-forbidden-admin/
  22. I think the server is in USA, probably Denver. I am pretty sure( from memory) the stores time zone is set for perth. However there is an issue with logging in as the 403 Forbidden raises its head with shop/admin. re home1/maketext/public_html/ admin I will change the name from admin to administ and see what happens. with the result of No change to shop and no change re login to admin.
  23. Thats true Brian, and I do not know why there is an admin folder under /home1/maketext/public_html/ anyway Here is the current globals.inc.php, without any of the above <?php $glob['adminFile'] = 'admin.php'; $glob['adminFolder'] = 'admin'; $glob['dbdatabase'] = 'mart1'; $glob['dbhost'] = 'localhost'; $glob['dbpassword'] = '0i0'; $glob['dbprefix'] = ''; $glob['dbusername'] = 'ma1'; $glob['encoder'] = 'ioncube'; $glob['installed'] = '1'; ?>
×
×
  • Create New...