Jump to content

Unable to checkout as guest with Invisible ReCAPTCHA


bsandall
 Share

Recommended Posts

Let this be a learning lesson to everyone that modifies their own code.  The reason my invisible recaptcha didn't work - I had made changes to my content.checkout page and forgot to put the highlighted portion back: It seems to be working now.

<button type="submit" name="proceed" id="checkout_proceed" class="button checkout right nomarg-bottom g-recaptcha"{include file='templates/element.recaptcha.invisible.php'}>{$CHECKOUT_BUTTON} <svg class="icon"><use xlink:href="#icon-chevron-right"></use></svg></button>

I'm sorry I bothered everyone with this - but on a happy note Dirty Butter told me how to disable guest purchases!

Please resolve this

Link to comment
Share on other sites

On 5/13/2017 at 5:25 PM, Claudia M said:

Please resolve this

But it's not resolved for me, and I was the one who started the thread... :\

I use version control to manage changes to my store's code and can quickly compare the files to the code from GitHub - none of my skin files are missing that code and it still has not worked for me.

I will re-test the invisible reCaptcha after 6.1.8 is released and update this thread with my results.

Link to comment
Share on other sites

Hmmm I wrote a response, but it's disappeared! Anyway - sorry about marking it Resolved too soon. I thought your issue has been fixed, but I read back through every comment and it's obviously not fixed for you.

I've asked twice that the OP should be able to mark the Resolved themselves. But evidently it's not available with this forum software.

Link to comment
Share on other sites

Ok I spoke way to soon ...  I'm having the same issue as bsandall in the first post.  Getting the error message:  The verification code was incorrect. Please try again. Also when I reentered the password, but not the email I get the error message:  %&;s ( or something close to that) is not a correct email.

 

 

Link to comment
Share on other sites

You asked:  Does it work if person registers as they fill out order information, or do they have to register and then add to basket?  .....  I was filling out the contact and billing info after pressing the secure checkout button on the mini basket.  It did not work and I got the error messages.  I have not tried from the register button.  I've turned recaptcha off for now until this is fixed.

 

Link to comment
Share on other sites

@Dirty Butter The reason I didn't make a GitHub issue originally is because I wanted to determine steps to replicate the issue, since it's nearly impossible to fix an issue that you can't replicate (as Al and any other developer can attest to). ;)

That said, good luck @Al Brookbanks - you've been on a roll lately! I suspect you haven't been sleeping as I see you online at odd hours of the night (your time).

Link to comment
Share on other sites

I'm really strict about working hours. I start between 8am and 9am and finish at 5:30pm. I'm a big believer is separating work and family/social time and for me CubeCart is 100% work even though I enjoy it very much (most of the time).

Saying this (like right now) I check email and respond to things like this. Not a huge amount of brain power is involved.

I had a brief look at this issue today but wasn't able to come to a conclusion. I hope to take another look in the morning.

  • Like 1
Link to comment
Share on other sites

  • 5 weeks later...
  • 11 months later...

This is happening to me too on 6.1.14 - when a guest customer completes their address details, the Secure Checkout button won't proceed.  Also, when a guest tries to register, the Register button won't work.  I've tested this with reCAPTCHA off and also v2.

I have a heavily modded checkout, but I haven't touched the registration page.  I'm thinking that if the registration page is having the same problem then there might be a shared script.

I did try the vanilla Foundation skin and everything did work OK - registration was OK, checkout as guest was OK (both with reCAPTCHA v2) - so I'll be comparing my modded version to track down why.

 

Link to comment
Share on other sites

After searching through code changes and not finding anything:

  • I renamed my custom skin folder by adding a few characters (BOB11)
  • Made a copy of the Foundation folder and renamed it to my original custom skin name (BOB)
  • Replaced the config file in my new skin (BOB) with my old custom skin config (BOB11)
  • Uploaded the new skin (BOB) to my site - so a fresh Foundation skin with my old config

After that, I copied back the images, js and css folders - no issues with the site.

Then I copied back any changed template files, two or three at a time.  Each time I used Admin/Maintenance to clear the cache in Cubecart, then tested on Chrome, Firefox and Safari (clearing browser caches and reloading the page from source).

I performed more than 30 tests on multiple browsers before all files were back and couldn't find any problem - a few blank screens at the gateway stage but that seemed to resolve itself after a while.

So maybe there was some issue with the original files (done as an upgrade using the setup folder).  A fresh upload of the Foundation skin and then adding back the modified files and cleaning the cache seems to have fixed my problem - BTW very similar to this one: https://forums.cubecart.com/topic/52443-register-and-checkout-not-working/

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...