Jump to content

Recommended Posts

That might be an issue, as a bug crept into the auto install when they started adding the CSRF hardening. It would be best if you followed the directions for the manual install for 6.1.8. It's supposed to be fixed from 6.1.8 on. Be sure the 6.1.8 version of the files is in the admin_XXX folder and admin_XXX file that matches what is in your includes/global.inc.php AND there are no other named admin folders/files.

Link to post
Share on other sites

Yes, I have the two references in global.inc.php but pointing to different admin folders, eg admin.a1234 on the first line and admin.z0987 on the second line.

I have done a manual install again via FTP on 6.1.8 but software said I have already updated to the latest version.

Am I able to manually update backward, back to  6,1,7 and might wait for another update later in the year.

Link to post
Share on other sites

You can edit the global.inc.php file to remove the erroneous admin folder. You want to KEEP the admin folder naming that corresponds to the admin folder with 6.1.8 files in it.

You will probably have to change permission to make changes to it, and then change back to 444.

But be warned that I have NEVER seen a forum post on here with two admin named folders in the global.inc.php folder.

Link to post
Share on other sites
5 minutes ago, Dirty Butter said:

But be warned that I have NEVER seen a forum post on here with two admin named folders in the global.inc.php folder.

 

Yep, that's me, I am a special type of stupid! I will bring the broken and unusual to the forum.

I will have a look at the code line you mentioned.

Link to post
Share on other sites
14 hours ago, Dirty Butter said:

But be warned that I have NEVER seen a forum post on here with two admin named folders in the global.inc.php folder.

I agree and I have never seen that before and cant imagine a way, unless manually added, how it could happen

Ian

Link to post
Share on other sites

No idea how I did it, I did once reinstall a backup in Cpanel when having trouble with my admin login, I think my cart is pretty broken, I don't really wish to continue working on it if not stable or set up right. Can I rollback the cart to an earlier version that just had the simple admin login and not admin.xxxx. I have already invested in the ebay software by noodleman and using that for ebay orders with no problems.

Link to post
Share on other sites

Before you basically "give up", it costs $40 I think for one month's tech support from CubeCart. They should be able to go in to your files and database and fix your issues. If you roll back and stay at that level you are leaving yourself open to possible security issues from now on.

Link to post
Share on other sites
12 minutes ago, Dirty Butter said:

Before you basically "give up", it costs $40 I think for one month's tech support from CubeCart. They should be able to go in to your files and database and fix your issues. If you roll back and stay at that level you are leaving yourself open to possible security issues from now on.

Yep, that sounds like a plan, I have invested time and money in the past few months into this cart but never realised I had made major errors on the upgrades. I will look into tech support and see if they can sort it out. Thanks

Link to post
Share on other sites

The other option is if you are interested in moving your hosting, then we provide free and full support for CubeCart as part of our E-Commerce packages, and can sort this out for you.  I will do the migration of your site over to one of our servers for free as well !

Ian

  • Like 1
Link to post
Share on other sites

I have seen Al Brookbanks apology for the upgrade problems, but I still do not know what to do.

I am on 6.1.1 so when I click the link to upgrade to 6.1.8 the maintenance page says I am using the latest upgrade already.

I am sure in the past when I have done this the auto tool takes over.

So does the auto tool still work or do we have to do manual upgrades now?

Is there a difinitve answer or is it a case of taking pot luck?

Link to post
Share on other sites

I suggest you do a manual upgrade as others have suggested.

As DB has suggested you will need to edit includes/global.inc.php to align with your file and folder name.

<?php
$glob['adminFile'] = 'admin_abcdef.php';
$glob['adminFolder'] = 'admin_XYZABC';
$glob['cache'] = 'file';
$glob['dbdatabase'] = 'database name';
$glob['dbhost'] = 'localhost';
$glob['dbpassword'] = 'password';
$glob['dbport'] = '21';
$glob['dbprefix'] = '';
$glob['dbsocket'] = '';
$glob['dbusername'] = 'username';
$glob['installed'] = '1';
?>

 

If you think this is too much then I suggest you talk to Ian regarding hosting or subscribe to Cubecart tech support  and have them install it.

All the best

Link to post
Share on other sites

Until you get to version 6.1.8 you will have to upgrade manually. We're seeing a lot of posters here on the forum who have some newest files and some older files in their install. Sounds like you are one of them.

The bug that crept in that is causing the upgrade issues is supposed to be fixed in 6.1.8, so upgrading to 6.19 should work with the admin link to upgrade automatically.

For all our sanity's sake I sure hope that turns out to be true!

Link to post
Share on other sites
7 minutes ago, harrisorganic said:

I suggest you do a manual upgrade as others have suggested.

If you think this is too much then I suggest you talk to Ian regarding hosting or subscribe to Cubecart tech support  and have them install it.

Thanks for the shout out !  A manual upgrade is the only sure way and part of the problem is that trying to upgrade from one specific version (say 6.1.1 or 6.1.2 etc) to the latest version can create different problems which need different solutions.  You will have a mix of files at different versions, DB may be at correct or incorrect version and the admin renaming may be messed up - hard to tell without looking at the files via FTP

Ian

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...