Jump to content
Sign in to follow this  
Claudia M

Default Inches not Centimeters in Product Dimensions

Recommended Posts

I cannot think of a reason why I would use centimeters instead of inches for my product dimensions in admin/products.  is there anyway to change this to have inches as the default?

Thanks in advance,

Claudia

842279376_ProductCentimeters.PNG.50aa81f5f738085576045ce8bb56ba44.PNG

Share this post


Link to post
Share on other sites

We could add the default to Store Settings, and still have the selector for when it does make sense - for whatever that would be.

Share this post


Link to post
Share on other sites

In Europe we have the metric system and centimetres is default. CubeCart is geared up predominantly for its home market 

Maybe we should have a default setting for imperial/metric. :)

Share this post


Link to post
Share on other sites

Where would I find the code to default this to inches? I would like my product dimensions to default to inches, but I believe my admin skin is custom so I dont have the selection option in the store settings. 

 

 

Share this post


Link to post
Share on other sites

This setting is not in Store Settings. It is in each product's Add/Edit, General Information tab.

In the admin template products.index.php, near line 174, find:

<select name="dimension_unit" id="dimension_unit">
  <option{if $PRODUCT.dimension_unit=='cm'} selected='selected'{/if} value="cm">Centimeters (cm)</option>
  <option{if $PRODUCT.dimension_unit=='in'} selected='selected'{/if} value="in">Inches (in)</option>
</select>

If the inventory record has not recorded the dimension unit ('cm' or 'in'), the first <option> will show as the default choice. To get a default of 'in', make sure it is the first option of the select list.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...