Jump to content

Address cannot be saved


Recommended Posts

  • 2 weeks later...

* CubeCart believes the form submission is in a session that does not have a user "logged in"

my error_log file has this

[27-May-2015 14:40:29 UTC] PHP Warning:  Stored session data did not match DB record. Session aborted as possible session hijack. Old IP Address: '' New IP Address: '' Old User Agent: 'Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36' New User Agent: 'Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36' in /home/subliprinting/public_html/shop/classes/session.class.php on line 650


is this related to above?


How I Fix this? (we have lot of error like this)

Problem seems to be users who has saved login since we had CC3 as cookie and now website is CC6 ?

is there a way to log out these old users automatically now (making cookies invalid by changing name of cookie etc.)

any help will really help





Link to comment
Share on other sites

Every time a user upgrades their browser, the session is killed. So, if the user cannot repeatedly attempt to save an address, then having had the browser upgraded is not a contributing factor.

You can change the name of the cookie in the file ini.inc.php. Find PHPSESSID and change it to, for example, NAMEOFSTORE. But I believe this is not a contributing factor, either.

Link to comment
Share on other sites

The database history jumped from 5.x.x to 6.0.3 missing 6.0.0 and 6.0.1 and 6.0.2. I don't know why. Running the upgrade scripts again fixed it. 

​In order to run the update scripts again, is it necessary for me to roll back to 5.13 backup and upgrade incrementally to 6.0.4?
This will mean I need to enter in any new customers since that date and any changes made to products and store.

OR, can I just FTP the scripts onto the existing 6.0.4 store and run them?

Link to comment
Share on other sites

For this purpose, do not restore your database from an old backup.

Instead, if you believe the database was not upgraded properly, look in the CubeCart_history table.

The history table shows the steps that the database upgrade went through.

If you really want to have CubeCart rerun the database upgrade scripts, delete only those records in the history table that are higher than 5.2.13 (or is it 5.1.3?).

If you renamed the /setup/ folder, rename it back to /setup/. If you deleted the /setup/ folder, FTP just the /setup/ folder back to your site.

Then go directly to www.store.com/setup/index.php. Choose the option to keep the existing database, and let the setup upgrade it.

If any part of the previous upgrade steps failed, this upgrade should catch and make those upgrades. If any part of the previous upgrade succeeded, then these upgrade scripts may be attempting to upgrade something that no longer exists, or already exists. But that's fine.

Link to comment
Share on other sites

I expect I'm in the wrong place:
Dashboard >Maintenence > Database - tables,  I can see

abcedgec_storegb.eui_CubeCart_history16MyISAMutf8_unicode_ci2.31 KB

 but I can't look in it, view it's contents or get in there to delete records in it from there.

I've searched my cubecart directories and can't find any reference in their for CubeCart_history table.
I'm guessing I do it through Query Database (Advanced)?

Sorry, as I said previously, I'm not a programmer. Speak to me like I'm stupid ;)
Again, thanks for your time.

Link to comment
Share on other sites

bsmither and Al Brookbanks, I could kiss your foreheads! It now works :w00t:

Thank you so much for your time -  I owe you both a beer!

For anyone else with this problem, this is what I did:

Used phpMyAdmin in cPanel,
clicked on the Databases tab,
selected my store,
selected eui_CubeCart_history,
deleted all version entries after 5.2.13
FTP'd 6.0.4 setup folder to store directory,
using a web browser went to mydomain.com/mystore/setup/ (substitute your stores directory)
chose upgrade existing store

Tested and fixed - I just hope nothing else has screwed up ;)


Edited by tonetas
Link to comment
Share on other sites

Happening here now. v6.0.4 From new customer:

Every time I try to add and save a delivery address the message 'The following errors were detected: Failed to save address' appears and I can go no further (I've tried adding details a few times now). Any suggestions?

Will an uprade to v6.0.5 fix this issue?

Edited by vidmarc
Link to comment
Share on other sites

I cannot say. What has been reported is that an upgrade from a version of CC5 (CC4?) to CC6 missed some steps in getting the database schema changed to the CC6 configuration.

By removing some of the CubeCart_history records, then having CC6 go through the setup process -- that reruns the database upgrade steps between the last version in the history table to the version running setup.

If the history table has 6.0.4 as the last record, then upgrading to CC605 will not help because (and if a bad schema is the cause) CC605 will run only that one script that changes 6.0.4 to get to 6.0.5.

There is no diagnostic feature/function in CubeCart that will compare the current database schema with a supposedly correct schema for that version.

What you can do is to get phpMyAdmin to show you the table schemas for CubeCart_customer and CubeCart_addressbook, and compare them with the CREATE TABLE statement in /setup/db/install/structure.sql.

Link to comment
Share on other sites

All the upgrades appear to be present in the upgrade history, so we are not able to figure out what is causing this problem. Does Al have any suggestions as to what could be causing this?

We asked the would-be new customer tio try a different browser:

Tried Firefox and Chrome. Same message appears. :-(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...