Jump to content

Recommended Posts

This page isn’t working

www.paypal.com is currently unable to handle this request.

HTTP ERROR 500
I get this with all versions please help
 

Share this post


Link to post
Share on other sites

Sadly we are still experiencong problems with this plugin, and have had to mothball the site until this is fixed.

Numerous problems.

Quote
 
"I just tried again and at the checkout screen after I tap on pay with PayPal it shows me a symbol like a padlock and sends me back to the checkout screen. I hope this info helps."
Quote

Sale is live now but tons of people are unable to check out. Like TONS. Need assistance ASAP. Can you help? 

 

 

Share this post


Link to post
Share on other sites

This should all be fixed up now in the 1.3.11 release. Onboarding is now resolved thank to the help from the guys at PayPal. 

ALso if the front end is returning JS errors please upgrade to 1.3.11 then disconnect and then reconnect via the module configuration page and all should be ok. 

Share this post


Link to post
Share on other sites

Is this only for UK, France, Italy, Spain - or is it going to work for all countries including Australia/New Zealand?

Is this only for Cubecart 6.2.9 and php 7.4.7, or will it work for older versions like 6.1.14 and php 7.0.33 (or older v6 cubecarts and php 5.6)?

More generally, are plugin updates being recommended by cubecart always compatible with the version of cubecart and php that is currently installed?

Share this post


Link to post
Share on other sites

Generally, that cannot be said. For example,

Noodleman's plugins require a specific version of that plugin to match the version of PHP and matching ionCube loader being used. It may take a short amount of time before a relevant encoded version becomes available for the newest version of PHP for any of his plugins.

CubeCart skins originally developed for CC5 will most likely run in the latest version of CC6, but these skins won't be updated to implement the complete range of functionality CC6 offers.

If you are referring to the announcements that your installation of CubeCart fetches from CubeCart HQ about available new versions of extensions that you have installed, I do not yet know 100% if there is any "version-check" being done when requesting these announcements.

Share this post


Link to post
Share on other sites
On 6/27/2020 at 6:19 PM, bsmither said:

Noodleman's plugins require a specific version of that plugin to match the version of PHP and matching ionCube loader being used. It may take a short amount of time before a relevant encoded version becomes available for the newest version of PHP for any of his plugins

This also applies to our plugins and we will always make available versions of each plugin suitable for PHP 5.6 and 7.0, a second version suitable for PHP 7.1 and finally a version suitable for PHP 7.2 and 7.3.   Currently ioncube have not released loaders or encoders for PHP 7.4 although beta versions are available so it wont be too much longer at which point there will be a 4th different version.  It should be taken into account that PHP 5.6 and 7.0 are seriously out of date and have known security issues that are not being patched - sites running on these (and even 7.1 which is also now out of maintenance support) should be moved to PHP 7.3

 

On 6/27/2020 at 6:19 PM, bsmither said:

If you are referring to the announcements that your installation of CubeCart fetches from CubeCart HQ about available new versions of extensions that you have installed, I do not yet know 100% if there is any "version-check" being done when requesting these announcements

There is no version check and generally latest versions of plugins are designed to be run and compatible with the latest version of CubeCart.  While it is rare that a change in CubeCart version causes problems with plugins, it has happened and while it is sometimes possible to recode a plugin to work in a generalised way to cover all CubeCart versions, sometimes it is impossible.  It would also be impossible to have different versions of plugins to cover different versions of CubeCart (even in the few cases where this is absolutely needed) - moral of all of this, is always keep your store running on the latest version of CubeCart and one of the currently supported versions of PHP (bearing in mind the availability of ionCube) and therefore NEVER make changes to core CubeCart where at all possible.

Ian

Share this post


Link to post
Share on other sites
Posted (edited)

It would help more people than just me if plugin release notes specified which version of CubeCart they were designed for (not just v6).  It would also help if older plugins were still available rather than being redirected to a new version that may not be compatible with my store.  Yes, I understand that keeping CubeCart bog standard makes things easier, but it doesn't meet every business need so my own upgrades are more difficult and  spaced further apart.

Back to my original question: Is the PayPal Commerce plugin only for UK, France, Italy, Spain - or is it going to work for all countries including Australia/New Zealand?

Edited by jasehead

Share this post


Link to post
Share on other sites
Quote

 Is the PayPal Commerce plugin only for UK, France, Italy, Spain - or is it going to work for all countries including Australia/New Zealand?

It's available pretty much world wide. Few countries are excluded. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...