Jump to content

havenswift-hosting

Member
  • Posts

    2,753
  • Joined

  • Last visited

  • Days Won

    84

Everything posted by havenswift-hosting

  1. This is not the way to upgrade at all - take backups of files and databases and then follow https://support.cubecart.com/Knowledgebase/Article/View/228/43/how-do-i-upgrade-from-cubecart-v6-to-latest-v6 Ian
  2. This is a database error as it is saying a table that the query is looking for doesnt exist. This will not be a skin error Ian
  3. If you just want customer records and there are no orders then export via phpMyAdmin from old database and import into new database Ian
  4. I agree with @Noodleman - my take is that the advice you are being given is incorrect. Also, from your wording above, a customer placing an order is entering into a contract with you and the reason for collecting the information is totally different and the length of time you need to keep it is also totally different. Contractual and marketing reasons are totally different. Legitimate Interest doesnt apply to marketing newsletters ! The processing must be necessary. If you can reasonably achieve the same result in another less intrusive way, legitimate interests will not apply.
  5. Even though the RC-2 update is showing in store's dashboards as being available - it shouldnt be used on a live site. If you are on a pretty recent V6 release, then there should be no need to upgrade anyway as far as skin compatibility is concerned Ian
  6. There is no need to do this but it should be covered in your Privacy Policy. Having any consent pre-selected will not be allowed under GDPR. You were part of a previous discussion where I summarised the basic points - see It will from technical point of view but the main area of work is down to each customer to update their Privacy Policy and Terms and Conditions based on the decisions taken as to data use and retention.
  7. A manual upgrade will always work and is the method I always use for all sites - if you are getting these errors then the upgrade via the admin upgrade option will always fail. This problem seemed to start after switching to the "new" unzip function a while back. Interestingly, WordPress websites on the same servers where I have seen these failures are able to upgrade using their built in utility without any issues
  8. It is almost impossible to say what is causing your issue based on the information we have to date. It could be lack of Server resources, it could be that the files haven’t been correctly updated (a manual upgrade instead of the built in admin function is the only reliable way to upgrade)or it could be any number of other causes. If you previously tried to follow the Admin upgrade, then I suggest that you try a manual upgrade from scratch Ian
  9. Zopim Chat which is now called Zendesk has that feature and there is a free extension developed by @Al Brookbanks that works really well. See https://www.zopim.com/product/ for details and https://www.cubecart.com/extensions/live-help/zendesk-live-chat-with-customer-and-basket-data for the extension itself. We use Zendesk chat ourselves on quite a few websites and it works very well Ian
  10. The only way it can do this is if when doing a manual upload / upgrade, you don’t upload the Admin files to the correct location. If you already have a renamed Admin directory you MUST upload the contents of /admin from the zip file to the current renamed directory and also Admin.php should be renamed to your admin_xxxxxx.php file BEFORE you run setup
  11. Everything you say about your Hosting company and their explanation sounds pretty dodgy to me. CubeCart isn’t perfect with it’s use of database resources and likewise with the way that caching works, which in turn increases database accesses, although this could be a lot better once 6.2.0 is released, however it is far better than a lot of other similar systems. The only possible reason for requiring you to create a new dB username / password would be if they thought that this had become public. MySQL timing out and a server needing to be rebooted several times in short succession dictates a vastly over populated / busy Server and would just love to hear their explanation as to hwhere w your account can switch php versions after a reboot !! PHP 5.6 should be the very bare minimum you should be using but 7.0 and better still 7.1, are much better and significantly faster than 5.6 Ian
  12. Hi Richard Drop me a PM and we can have a chat Ian
  13. Take a look at our Retail Therapy skin here https://www.cubecart.com/extensions/developer/havenswift-hosting which comes with a free Skin Configuration plugin which we are continually expanding and adding features and functionality to
  14. PayPal along with all other payment gateways have been sending out emails to all users for about a year saying that TLS1.2 will be required and older insecure protocols will not be supported and as the user here appears to be using 1.0.0 (even that is deceptive as many distributions dont upgrade openSSL but back port security patches). I would expect that the INVALID response will be caused by that but as all of our servers were TLS1.2 compliant four or five years ago, have never come across this. All payment providers have only just been forced into using TLS1.2 so it is going to be a VERY long time before they force TLS1.3 - it was only released less than a year ago and cPanel for example doesnt even support it yet.
  15. Completely agree that you will have a mix of file versions - using the admin update tool on older versions doesnt work and causes partly upgraded sites, and it also messes up the naming of the admin.php and admin directory if you had already renamed them to the obfuscated versions
  16. OpenSSL 1.0.0 is massively old and contains a huge number of security risks - version 1.0.1 is the minimum required for TLS1.2 but even that is full of holes - upgrade to the latest version
  17. If using options matrix, then the plugin from @Noodleman https://www.cubecart.com/extensions/plugins/absolute-matrix-option-prices-price-list-hide-out-of-stock-matrix-options is a fantastic addition
  18. OK then I would suggest rechecking the various commits for that issue to check you added everything correctly and if you are certain it was all done OK, then there could be another cause although I can’t see how a firewall would be blocking it. Foundation works perfectly across multiple sites / hosting servers and I recently added it to two of our skins and those are working on multiple client’s sites as well
  19. To request a new feature, you can go here : https://features.cubecart.com/ but the chance of it being in the next upgrade I suspect is slim to none ! Many people think their requirement is a simple and obvious need that everyone would want ! Adding a link to a product description can be done via the editor
  20. What skin are you using and why do you think that the Invisible recaptcha code has been added. Apart from core Foundation, very few third party skins have had the changes done
  21. This plugin has today been upgraded to V1.2 and this version should be used if installing Retail Therapy skin V1.8 or Nautical skin V1.3 New features added include * Integration with Google Tag Manager * Added option to remove the sidebar on all pages * Added option to remove the mailing list signup * Added ability to choose to use Google Translate which replaces the standard language selector
  22. Version 1.8 has just been released and this contains a couple of minor bug fixes and layout enhancements plus also a lot of additional integrations and functionality improvements New features added in this release include * Integration with Smartlook - Take a look and sign up for your free account of this fantastic service here : https://www.smartlook.com/?_ak=QrCqPqfMK * Integration of Google Tag Manager code * Integration of Google Invisible ReCaptcha * Integration with Noodleman Absolute Option Matrix Prices plugin * Addition of accordion effect when using Multiple Homepage Documents plugin * Add option to remove sidebar on all pages except homepage (which doesnt have it anyway) * Add option to remove Mailing list signup from the store * Ability to choose Google Translate and remove standard language selector if enabled * Integration of Google Survey opt-in * Addition of shadow boxes around certain content * Fix bug with magnifier function
  23. You could offer free shipping and then build the shipping cost into the product price although that doesn’t work so well if you ship to multiple regions that have very different shipping costs. If this is the case, then you will probably need to use a more complex configuration and the plugin from @Noodleman would probably come in handy https://www.cubecart.com/extensions/shipping-methods/link-cubecart-products-to-specific-shipping-services-/-modules Ian
  24. There is no ";" at the end of your queries and if all are copied and pasted together then will be executed as one (or at least attempted)
×
×
  • Create New...